Support » Plugin: Login With Ajax » Issue with Jetpack Protect

  • Hi,

    on a multisite install with Jetpack Protect enabled, the users occasionally cannot login via LWA. They get the message ‘an error has occured, please try again’.

    Login via wp-login.php works fine in that case. After disabling Protect, LWA works again.

    Whitelisting IP’s is not really an option, since all users have to login to read the content (it’s a paywall site).

    I already asked the Jetpack team for help. Jeremy Felt offered a patch which seemed to solve the problem at first. But it sometimes reoccur, unfortunately, also with the patch applied.
    https://wordpress.org/support/topic/conflict-with-ajax-login/#post-8692563

    Do you guys have any idea?

    Thanks and best Regards,
    Steffen

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support caimin_nwl

    (@caimin_nwl)

    Hi Steffen,

    Which version of Login With Ajax, Jetpack and WordPress are you using?

    Thread Starter Steffen Dressler

    (@steffend)

    Hi Caimin,

    Thanks for your answer.

    Here are the versions I am using currently:

    Login with Ajax:3.1.6
    Jetpack: 4.7.1
    WordPress: 4.7.3

    Unfortunately, I do not know with which version(s) the issue first came. Maybe it was linked to introduction of Protect’s math questions.

    Plugin Support caimin_nwl

    (@caimin_nwl)

    It’s possible there is another conflict caused by your theme or another plugin. To check if it is, can you test with all other plugins deactivated and while running the default WordPress theme?

    I have had the same problem. It looks like the “Prove your humanity” challenge visible on the “normal” login page does not get displayed in the ajax widget.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Issue with Jetpack Protect’ is closed to new replies.