Support » Plugin: Admin Menu Tree Page View » Insecure Resources on SSL wp-admin

  • I absolutely love your plugin. I have a suggestion though. For users that have FORCE_SSL for their wp-admin, the plugin produces errors for insecure resources. If you modify your your wp_enqueue_style and wp_enqueue_script calls at line 45 with the code below it fixes this issue.

    wp_enqueue_style("admin_menu_tree_page_view_styles", plugins_url('/css/styles.css', __FILE__), false, admin_menu_tree_page_view_VERSION);
    	wp_enqueue_script("jquery.highlight", plugins_url('/js/jquery.highlight.js', __FILE__), array("jquery"));
    	wp_enqueue_script("jquery-cookie", plugins_url('/js/jquery.biscuit.js', __FILE__), array("jquery")); // renamed from cookie to fix problems with mod_security
    	wp_enqueue_script("jquery.ui.nestedSortable", plugins_url('/js/jquery.ui.nestedSortable.js', __FILE__), array("jquery", "jquery-ui-sortable"));
    	wp_enqueue_script("jquery.client", plugins_url('/js/jquery.client.js', __FILE__), array("jquery"));
    	wp_enqueue_script("jquery-ui-sortable");
    	wp_enqueue_script("admin_menu_tree_page_view", plugins_url('/js/scripts.js', __FILE__), array("jquery"));

    http://wordpress.org/extend/plugins/admin-menu-tree-page-view/

Viewing 1 replies (of 1 total)
  • Plugin Author Pär Thernström

    (@eskapism)

    Thanks for letting me know that it does not use HTTPS.

    Also thanks for the code. Altough that code does not work for me because I use symlinks and stuff in my development environment, but I have changed the way the scripts are loaded to a way that hopefully works with SSL too. Let me know if the updated version of the plugin works!

Viewing 1 replies (of 1 total)
  • The topic ‘Insecure Resources on SSL wp-admin’ is closed to new replies.