Support » Plugin: Server IP & Memory Usage Display » Incorrect data

  • Resolved w411


    I have seen this happen on multiple sites on different hosts in the last month or so:


Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author apasionados


    Hi @w411,

    This happens on some shared hosting environments. We get the used memory with the standard ini_get('memory_limit') function. And if this function returns -1 MB this is what we show. We really don’t know another way to retrieve this data.

    Have you installed any other plugin that shows this correctly? That would be a great help for us to trace how they retrieve this value.

    Sorry that we can’t help you this time.

    Best regards from Spain.

    Thread Starter w411


    That particular install is on a VPS with WPMU Dev which is not shared hosting, they use a managed version of Digital Ocean droplets for each website.

    Oddly, I disabled all other plugins, the information was reported correctly, and after I activated the other plugins one by one the information was still being reported correctly.

    If it happens again I will try disabling one by one until the error is corrected to get a better idea of which plugin could be causing the problem.

    Hello @w411 !

    I trust you’re doing well today!

    In this case if that happens on the WPMU DEV server, a possible thing to do here is to clear the Object Cache in the Tools tab on the Hub.

    Warm regards,

    When memory-limit is set to -1, that is a special value: it means that there is no restriction as to how much PHP is allowed to allocate. Calculating a percentage doesn’t make sense in this case.

    (The real memory limit could only be tried out … e.g. running such a script in WP-Cron : )


    Just to make it clear (in relation to what @benjamin4 – correctly – explained): we don’t use such value as “-1” on WPMU DEV servers. There’s a fixed value set for memory_limit but not -1, unless user set it so via the .user-ini file. It would still be “filtered” to the maximum allowed by “overall” configuration of the hosting plan anyway.

    Kind regards,

    Yes that might be a plugin trying to set memory_limit to -1.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.