Support » Plugin: WPSSO Core | The Complete Solution for Meta Tags and Schema Markup » Image previews NOT WORKING since update

  • Resolved seanadl

    (@seanadl)


    Constantly seeing featured images on random posts not show up on Twitter anymore. Since the latest plugin update, WPSSO seems to want to locate custom images with different sizes to the one explicitly set in WordPress, resulting in 404 for the images and resulting in images not showing correctly on social media.

    Anyone else experienced this problem?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author JS Morisset

    (@jsmoriss)

    As suggested in the ticket you opened for this issue:

    – Define the WP_DEBUG constant as true to make sure WordPress and PHP can create the required images (memory issues can prevent the ImageMagick library from working properly, as one example).

    https://make.wordpress.org/support/handbook/appendix/using-wp_debug/

    – Regenerate image thumbnails using a plugin like this one, which also fixes media library corruption issues. Also make sure there are no errors in the debug.log file (see above).

    https://wordpress.org/plugins/regenerate-thumbnails/

    – You can review the image sizes under the WordPress Settings > SSO Image Sizes page. You can also reload the default image sizes in the SSO > Tools page. And you can use a plugin like this one to review all image sizes (from WPSSO, other plugins, your theme, etc.):

    https://wordpress.org/plugins/simple-image-sizes/

    – You can also enable the SSO > Advanced > Integration > Enforce Image Size Checks option to have WPSSO double-check the image information returned from WordPress (which can sometimes be innacurate). WordPress can sometimes return an image size that is “close enough” for example (which might be the issue you’re seeing).

    – When editing a post/page, make sure there are no image related warnings (ie. full size image too small to create the image size, for example).

    js.

    Plugin Author JS Morisset

    (@jsmoriss)

    No feedback after several days, so we’ll assume the above suggestions were successful (setting this thread to resolved).

    js.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.