• Resolved setevoy

    (@setevoy)


    Hi.

    We use this plugin for our Stage and Prod environments hosted on Azure as WebApps.

    A problem is – on Prod after new image uploaded – WP says “HTTP error”:

    A HTTP error

    But on Stage, which use same Storage Account with same settings – everything works just fine.

    What can be a reason?

    Thanks.

Viewing 15 replies - 1 through 15 (of 27 total)
  • And yes – nothing helpful in IIS logs.

    Plugin Author Ritesh Patel

    (@ritteshpatel)

    Hi @setevoy

    Thanks for letting us know about this issue. You said, it’s working fine on your stage site. Is your stage site also using IIS? Can you also get us the HTTP request status for the upload request from browser’s console?

    Regards,
    Ritesh

    • This reply was modified 2 years, 12 months ago by  Ritesh Patel.

    Hi, @ritteshpatel.

    Thanks for replay. I contacted Azure support team also, maybe they will assist (files permission on Win boxes or something similar).

    > You said, it’s working fine on your stage site. Is your stage site also using IIS?

    Yes – both applications running as Azure WebApps on Windows hosts with IIS.

    Error is:

    > load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,plupload,plupload-handlers&ver=4.6.1:24 POST http://domain.com/wp-admin/async-upload.php 413 (Request Entity Too Large)

    (why I didn’t check it at first…)

    (full screenshot here: https://rtfm.co.ua/uploads/huber_upload_4.png)

    Hope this could help.

    • This reply was modified 2 years, 12 months ago by  setevoy.
    • This reply was modified 2 years, 12 months ago by  setevoy.
    Plugin Author Ritesh Patel

    (@ritteshpatel)

    Hi setevoy,

    Which size of image you are uploading? Have you tried the image which is in smaller size? Can you tell us allowed upload size and max post input size config of your site? I am guessing this is image size issue.

    Regards,
    Ritesh

    Indeed! Sorry – I completely forgot to mention it.

    Yes – 512k file with uploaded successfully (and this was told by developers when they came to with this issue).

    And sure – this bind to the “Request Entity Too Large” error message.

    P.S. I removed screenshot, please – say, if you still need it.

    • This reply was modified 2 years, 12 months ago by  setevoy.
    Plugin Author Ritesh Patel

    (@ritteshpatel)

    Hi @setevoy

    Can you check the max input size and max allowed upload size for your application? Your image size shouldn’t be greater than allowed size.

    Regards,
    Ritesh

    Hi, @ritteshpatel.

    From phpinfo (and this is the default for all web app on Azure App), here is the values:

    upload_max_filesize = 8MB
    post_max_size = 8MB
    Plugin Author Thorsten Ott

    (@tott)

    Hi @setevoy,

    can you give us some insights on your IIS settings especially uploadReadAheadSize and maxRequestEntityAllowed

    https://www.iis.net/configreference/system.webserver/serverruntime

    Also the maxAllowedContentLength limit might be of interest as per

    https://blogs.msdn.microsoft.com/azureossds/2016/06/15/uploading-large-files-to-azure-web-apps/

    In addition, can you confirm that uploads are working if you disable the azure storage plugin?

    Thanks
    Thorsten

    • This reply was modified 2 years, 12 months ago by  Thorsten Ott.

    Hi, @tott. Thanks for replay.

    I’ll ask Support about IIS parameters.

    Regarding disabling plugin… I just not sure it’s a good idea on Production πŸ™‚

    But what if I’ll create a new container or even account with data from current one – and will switch them in plugin’s settings?

    Plugin Author Thorsten Ott

    (@tott)

    Hi @setevoy,

    that would not help at this point. I was hoping to identify if the uploads issue is actually related to the azure storage plugin or a more general issue. Just changing the settings would not help us to identify this.

    Let’s see what the settings reveal.

    Best
    Thorsten

    Hi, @toot.

    OK, got it.

    I’ll check with our customer about an ability to disable the plugin. Guess – I could copy images directly to WebApp’s host. Will update topic today (and with uploadReadAheadSize/maxRequestEntityAllowed).

    Thanks.

    UPD
    > ability to disable the plugin
    Unfortunately – no, we can’t πŸ™

    • This reply was modified 2 years, 11 months ago by  setevoy.

    Hi, @tott. Here is information you asked for:

    The values on Azure App should take the same default setting with IIS. As reference from https://www.iis.net/configreference/system.webserver/serverruntime

    uploadReadAheadSize: The default value is 49152.
    maxRequestEntityAllowed: The default value is 4294967295 (unlimited).

    Plugin Author Ritesh Patel

    (@ritteshpatel)

    Hi @setevoy,

    The uploadReadAheadSize value id 49152 which is 49kb. Can you tell us for which maximum image size the upload is working fine?

    Regards,
    Ritesh

    Hi, @ritteshpatel.

    I had success with a 512kb file, but it fails with 1M and 4M data.

    Plugin Author Thorsten Ott

    (@tott)

    Hi @setevoy,

    could you try to increase the uploadReadAheadSize to a more reasonable value. Especially when working over SSL this limit can be reached pretty quickly and I think. I’d suggest setting a value of around 10 MB to align with your 8MB upload limits.

    Please let me know if this solves the issue

    Thanks
    Thorsten

Viewing 15 replies - 1 through 15 (of 27 total)
  • The topic ‘HTTP error’ is closed to new replies.