• Hi,

    After clicking save in the plugin, I got this HTTP ERROR 500 and there is no .htaccess.wppsb in the plugin root.

    How can I fix?

    Thanks

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Dipak C. Gajjar

    (@dipakcg)

    Are you able to find wp-content/wp-performance-score-booster folder? .htaccess.wppsb file should be located under it.

    If you can’t find the above-mentioned file, please paste the contents of your .htaccess file located under your WordPress installation root.

    Thread Starter maximmmus

    (@maximmmus)

    # HTTPS forced by SG-Optimizer
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{HTTPS} off
    RewriteRule ^(.*)$ https://%{SERVER_NAME}%{REQUEST_URI} [R=301,L]
    </IfModule>
    # END HTTPS

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress
    <IfModule mod_headers.c>
    Header unset ETag
    Header set X-Frame-Options: SAMEORIGIN
    Header set X-XSS-Protection: “1; mode=block”
    Header set X-Content-Type-Options: nosniff
    Header set X-Permitted-Cross-Domain-Policies: “master-only”
    Header set Content-Security-Policy: “upgrade-insecure-requests”
    Header set Content-Security-Policy: “block-all-mixed-content”
    Header set Content-Security-Policy: “default-src ‘self’; font-src ‘self’ https://*.wp.com https://*.fbcdn.net https://*.facebook.net https://ajax.googleapis.com/ https://fonts.googleapis.com/ http: data:; script-src ‘self’ ‘unsafe-inline’ ‘unsafe-eval’ http://*.wp.com https://public-api.wordpress.com https://apis.google.com http://www.google-analytics.com http://www.googletagmanager.com https://ajax.googleapis.com http://*.googlecode.com http://*.cloudflare.com http://connect.facebook.net/ http://*.twitter.com https://*.twitter.com http://www.semrush.com; style-src ‘self’ ‘unsafe-inline’ https://*.wp.com https://fonts.googleapis.com https://ajax.googleapis.com/; img-src * ‘self’ https: data:; child-src ‘self’ aff.bstatic.com https://www.booking.com https://public-api.wordpress.com https://widgets.wp.com http://*.facebook.com https://*.facebook.com https://buffer.com http://*.twitter.com https://*.twitter.com https://*.google.com; object-src ‘none’; ”
    </IfModule>
    # BEGIN Bad Bot Blocker
    SetEnvIfNoCase User-Agent “Abonti|aggregator|AhrefsBot|asterias|BDCbot|BLEXBot|BuiltBotTough|Bullseye|BunnySlippers|ca\-crawler|CCBot|Cegbfeieh|CheeseBot|CherryPicker|CopyRightCheck|cosmos|Crescent|discobot|DittoSpyder|DotBot|Download Ninja|EasouSpider|EmailCollector|EmailSiphon|EmailWolf|EroCrawler|Exabot|ExtractorPro|Fasterfox|FeedBooster|Foobot|Genieo|grub\-client|Harvest|hloader|httplib|HTTrack|humanlinks|ieautodiscovery|InfoNaviRobot|IstellaBot|Java/1\.|JennyBot|k2spider|Kenjin Spider|Keyword Density/0\.9|larbin|LexiBot|libWeb|libwww|LinkextractorPro|linko|LinkScan/8\.1a Unix|LinkWalker|LNSpiderguy|lwp\-trivial|magpie|Mata Hari|MaxPointCrawler|MegaIndex|Microsoft URL Control|MIIxpc|Mippin|Missigua Locator|Mister PiX|MJ12bot|moget|MSIECrawler|NetAnts|NICErsPRO|Niki\-Bot|NPBot|Nutch|Offline Explorer|Openfind|panscient\.com|PHP/5\.\{|ProPowerBot/2\.14|ProWebWalker|Python\-urllib|QueryN Metasearch|RepoMonkey|RMA|SISTRIX|sitecheck\.Internetseer\.com|SiteSnagger|SnapPreviewBot|Sogou|SpankBot|spanner|spbot|Spinn3r|suzuran|Szukacz/1\.4|Teleport|Telesoft|The Intraformant|TheNomad|TightTwatBot|Titan|toCrawl/UrlDispatcher|True_Robot|turingos|TurnitinBot|UbiCrawler|UnisterBot|URLy Warning|VCI|WBSearchBot|Web Downloader/6\.9|Web Image Collector|WebAuto|WebBandit|WebCopier|WebEnhancer|WebmasterWorldForumBot|WebReaper|WebSauger|Website Quester|Webster Pro|WebStripper|WebZip|Wotbox|wsr\-agent|WWW\-Collector\-E|Xenu|Zao|Zeus|ZyBORG|coccoc|Incutio|lmspider|memoryBot|serf|Unknown|uptime files” bad_bot
    Deny from env=bad_bot
    # END Bad Bot Blocker
    # BEGIN protect wpconfig.php
    <files wp-config.php>
    order allow,deny
    deny from all
    </files>
    # END protect wpconfig.php
    # BEGIN protect xmlrpc.php
    <files xmlrpc.php>
    order allow,deny
    deny from all
    </files>
    # END protect xmlrpc.php
    <FilesMatch “\.(ico|jpg|jpeg|png|gif|js|css|swf|pdf|flv|mp3)$”>
    <IfModule mod_expires.c>
    ExpiresActive on
    ExpiresDefault “access plus 14 days”
    Header set Cache-Control “public”
    </IfModule>
    </FilesMatch>
    <FilesMatch “\.(html|htm|xml|txt|xsl)$”>
    Header set Cache-Control “max-age=7200, must-revalidate”
    </FilesMatch>
    # BEGIN WP Performance Score Booster Settings
    # END WP Performance Score Booster Settings
    <Files 403.shtml>
    order allow,deny
    allow from all
    </Files>
    deny from 195.154.183.190
    deny from 91.200.12.58
    deny from 31.184.194.91
    allow from 46.229.173.66
    allow from 46.229.173.67
    deny from 91.210.147.58

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘HTTP ERROR 500’ is closed to new replies.