Support » Plugin: Rewrite Rules Inspector » Great tool!

  • Steven

    (@stgoos)


    Love the plugin but noticed today, whilst debugging a new plugin I’m writting, that the plugin still uses the depreciated functions: screen_icon() and get_screen_icon().

    Both have gone depreciated since 3.8.0 so I reckon a minor update to avoid these errors from popping up in the debug mode is worth the effort 🙂

    The fix – with backwards compatibility (do we need that?) – would be to change:
    <?php screen_icon( 'tools' ); ?>
    into:
    <?php if ( function_exists('screen_icon') ) screen_icon( 'tools' ); ?>

    ___

    (!) Notice: screen_icon is deprecated since version 3.8.0 with no alternative available.
    (!) Notice: get_screen_icon is deprecated since version 3.8.0 with no alternative available.
    Location ..\rewrite-rules-inspector.php:208

    • This topic was modified 2 years ago by Steven.
    • This topic was modified 2 years ago by Steven. Reason: Added the code to fix the problem
  • The topic ‘Great tool!’ is closed to new replies.