Support » Plugin: Shortcodes Ultimate » Google maps over HTTPS

  • Hi,

    The google maps shortcode is not usable on my client website because the iframe is called over HTTP instead of HTTPS. It triggers this error in chrome console :

    Mixed Content: The page at 'https://domain.com/contact/' was loaded over HTTPS, but requested an insecure resource 'http://maps.google.com/maps?q=...&output=embed'. This request has been blocked; the content must be served over HTTPS.

    Could you remove the protocol in shortcodes-ultimate/inc/core/shortcodes.php line 974 ? That way the su_gmap shortcode will work both over HTTP & HTTPS 🙂

    Thanks a lot.

    Séb.

Viewing 3 replies - 1 through 3 (of 3 total)
  • This would be very, very helpful. All that needs to change is to remove http:. No logic needed.

    same here

    please, remove the http: and it will use the correct protocol

    Tried to change that by hand, works like a a charm.

    Dear Vladimir Anokhin, I even bought your PRO Version of this plugin to support further development. This issue seems to be known for a while now, could we expext an update?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Google maps over HTTPS’ is closed to new replies.