Support » Plugin: Map My Posts » Google api

Viewing 7 replies - 1 through 7 (of 7 total)
  • I had the same error in the console. To fix it I had to include the API key in the script tag as well as the HTML markup. Before I only had it in the HTML which would work fine on the page but show the NoAPIKeys error in the console.

    ‘<script src=”https://maps.googleapis.com/maps/api/js?key=IncludeKeyHere”></script>&#8217;

    Thread Starter eyephone21

    (@eyephone21)

    Thanks ScottRMon!
    I couldn’t find where this script is…
    Help me, please! :=)

    I’ve added an api key as well. no luck (on bluehost).

    I thought I had fixed it by adding this line : <script src=”http://maps.googleapis.com/maps/api/js?key=MYKEYBLABLABLABA”></script&gt;; in the <head> section of admin-header.php in wp-admin folder of wordpress.
    That allows the map to load at least in the category or tag edit page of the wordpress admin, but it crashes seconds after that. Error log says the api key included several times on the page, though otherwise it says error no key.
    Try again.

    This is killing me…

    • Works great without API on dev server on 1and1; breaks with or without API on production on bluehost…
    • Installed on a new 1and1 plan and I swear it was working until I pointed the Domain (hosted at goDaddy) and it died. — could there be a domain issue?
    • I did the manual key addition to the header… I got the double key message too.
    • When I add a simple call to googlemaps it works:
      <div id="map" style="height: 700px;"></div>
          <script>
            var map;
            function initMap() {
              map = new google.maps.Map(document.getElementById('map'), {
                center: {lat: 47.16249, lng: 19.50330},
                zoom: 8
              });
            }
          </script>
         <script src="https://maps.googleapis.com/maps/api/js?key=DaKeyGoesHere&callback=initMap" async defer></script>
    • When I added both the simple call and the short-code for my maps I get an error that the page contains two maps..

    so interestingly the [mmp-geochart mode=”marker”] && [mmp-geochart mode=”region”] work fine…. ??? anyone from the plugin developer looking into this at all?

    Hi, OK so yes we add the API key as described here & here as mentioned above, wooohoo, so where is the file within the plugin?

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Google api’ is closed to new replies.