Support » Plugin: Jetpack by WordPress.com » function.json-encode

  • I’m using iThemes Security along with Jetpack. When I go to my iThemes Security Settings page, I see the following at the bottom of the page.

    [function.json-encode]: recursion detected in /home/content/55/7412555/html/wp-content/plugins/jetpack/sync/class.jetpack-sync-module.php on line 50
    
    Warning: json_encode() [function.json-encode]: recursion detected in /home/content/55/7412555/html/wp-content/plugins/jetpack/sync/class.jetpack-sync-module.php on line 50

    Any idea what is causing this?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Contributor Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Thanks for the report!

    Does this only happen on the iThemes Security Settings page, or anywhere else in your dashboard?

    Yes, this only appears on the iThemes security settings page. I’m constantly getting emailed regarding Site Lockout Notifications for my username. But when I go to the site, I’m able to log in fine. I can’t for the life of me find where to release lockouts.

    I’m wondering if there is incompatibility with iThemes Security and Jetpack.

    Plugin Contributor Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    I tried installing iThemes Security on a test site of mine, enabled all recommended modules in the plugin, but I couldn’t reproduce the issue I’m afraid.

    From what I can tell, you can configure lockout settings under Global Settings > Configure Settings. That feature doesn’t seem to cause issues or conflicts with Jetpack on my site, though.

    Could you try to deactivate all other plugins on your site, one at a time, and let me know if one of them appears to create that conflict with Jetpack, and output that notice on the iThemes Security Settings page?

    Thanks!

    This may take me a while to do because my client is currently directing traffic to their website to collect donations and memberships. It may be a few days before I can login late at night and try to disable plugins.

    Ok, this is getting tricky to test. Today I went through each of the admin pages and made note of each page that would display this error at the bottom. Now I just pulled up those admin pages and only found the error at the bottom of one of those pages.

    Settings > Media

    I refreshed the page and the error did not display at the bottom of the page. With that being said, even by disabling the plugins one by one, I won’t be able to see which plugin has any effect since this error does not display consistently on any one page.

    Perhaps it has something to do with something not loading fast enough, or properly, from the server?

    Plugin Contributor Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Could you add the following to your site’s wp-config.php file?

    
    define( 'WP_DEBUG', true );
    
    if ( WP_DEBUG ) {
    
            @error_reporting( E_ALL );
            @ini_set( 'log_errors', true );
            @ini_set( 'log_errors_max_len', '0' );
    
            define( 'WP_DEBUG_LOG', true );
            define( 'WP_DEBUG_DISPLAY', false );
            define( 'CONCATENATE_SCRIPTS', false );
            define( 'SAVEQUERIES', true );
    
    }
    

    Your wp-config.php file may already include a line that says “define(‘WP_DEBUG’, false);”. You can remove it, and replace it by the code above.

    Once you’ve done so, try to reproduce the issue, then check the wp-content/debug.log file for errors.

    You can paste the results here, and then replace define('WP_DEBUG', true); by define('WP_DEBUG', false); in the code above.

    Thanks!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘function.json-encode’ is closed to new replies.