Support » Plugin: SG Optimizer » Frontend Optimization Page is Blank

  • Resolved Boldt

    (@enso)


    The Frontend Optimization settings page is blank. Once on that page, the links to the other setting pages don’t appear so the only way to get back to one of the other pages is the Back button. Originally, that was the last page I was on during a previous login and I couldn’t switch to any other settings page under any circumstances.

    I’ve already deleted the plugin, cleared my browser cache, and re-installed SG Optimizer. Same problem.

Viewing 15 replies - 1 through 15 (of 21 total)
  • Plugin Author Stanimir Stoyanov

    (@sstoqnov)

    SiteGround Representative

    Hey @enso

    Please provide your website url

    Regards,
    Stanimir

    I noted this same error during a support chat a couple of days ago and was told to clear my cache or change browsers. I have always used Chrome and that’s where the issue happened – initially only on some sites, then within a couple of SGO tab navigations, to all.

    Is this really the answer we get? Don’t you folks fully test things before you put them out to users?

    On top of that, this morning I am getting Wordfence file change notifications. I am running the current version of SGO and no update has been published. So wht would the following notice come from Wordfence when nothing has been changed:

    == Medium Severity Problems: ==

    Modified plugin file: wp-content/plugins/sg-cachepress/core/Admin/Admin.php

    Plugin Author Hristo Pandjarov

    (@hristo-sg)

    SiteGround Representative

    Ignore the wordfence report, it is a false positive. We’ve did a repo commit without version bump because of a minor css change.

    As to the blank screen issue it is something in your site. We cannot troubleshoot further without your URL. So, if you want us to assist, you – kindly provide it.

    SGO tabs/pages were clearly visible for as long as I can remember AND I’ve always used Chrome for admin purposes. No new plugins have been added since the last SGO update. So saying that the problem is within our site(s), especially since this is only evident in Chrome, is pretty laughable. I am using SGO on over 10 web sites and many have the same problem when viewing the #frontend tab content in Chrome – only since your last SGO update.

    More importantly, using a different computer, while using Chrome, I got no such error.

    Explanation?

    Plugin Author Hristo Pandjarov

    (@hristo-sg)

    SiteGround Representative

    I am afraid not. I can’t troubleshoot your browser or unknown websites. I am marking this as solved because that’s something with your particular installation and not a general plugin issue. Most probably combination of browser caching and Wordfence or other security plugin blocking incorrectly the rest api. However, without more information I can only speculate.

    I can confirm that it only happens in Google Chrome. It doesn’t occur in Firefox or Safari.

    Resolved? Definitely not.

    I am afraid not. I can’t troubleshoot your browser or unknown websites. I am marking this as solved because that’s something with your particular installation and not a general plugin issue.

    I opened this topic before I went to bed last night and you closed it based on someone else’s comments before I woke up this morning. Good job.

    Plugin Author Hristo Pandjarov

    (@hristo-sg)

    SiteGround Representative

    The topic is resolved because it’s not a plugin issue. If you provide us with your URL, we can check and help you out but without it there’s nothing we can do.

    The topic is resolved because it’s not a plugin issue.

    You closed it before I could even give you the info you asked for! You didn’t know whether my issue was the same as the other guy’s. From my perspective, when you closed the topic you slammed the door on me getting any help. I’m going to have to reconsider recommending Siteground to my clients if this is the kind of support they’ll get.

    Plugin Author Stanimir Stoyanov

    (@sstoqnov)

    SiteGround Representative

    Hey @enso,

    Sorry for the misunderstanding. Please, provide us with your URL and we will look into it.

    Regards,
    Stanimir

    Found the problem. Once I cleared cookies for the website it started working. I’d only tried clearing the cached data previously. Not sure which cookie it was, but it’s fixed now. Does SG Optimizer set any site cookies that might be causing that problem?

    If it happens again I’ll take a look at the cookies in more detail before clearing them.

    Plugin Author Stanimir Stoyanov

    (@sstoqnov)

    SiteGround Representative

    It’s not the cookies but the localstorage. We store the state of the app there.

    Regards,
    Stanimir

    OK, got it. Perhaps add an option to clear the localstorage?

    @enso have you tried to open this website in another computer o even other browser ?

    I have the same issue and changes only stay on my computer.
    It means that settings are not sent to the server.
    Besides, PHP version in tab “environment” is set as 0

    First, I found a blank page.
    Then, if deleted cookies, SG Optimizer seemed to work again.
    But unfortunately, I see that settings are only in Chrome. If I move to Firefox or Safari settings are un-set. So settings are not in the server.

    Regards

Viewing 15 replies - 1 through 15 (of 21 total)
  • You must be logged in to reply to this topic.