Support » Plugin: Contact Form 7 » Forms cannot be submitted since 17 december

  • Resolved onepack

    (@onepack)


    All forms have problems since 18 December 2018.
    This is after the update from contactform where the Google capcha V3 keys were mandatory.
    These keys have been added but with no success.
    All my tests now result in a spam message.
    “Failed to send your message. Please try later or contact the administrator by another method.”
    Also checking Flamingo shows me the form submits are handled but all my tests are marked as spam.
    I checked for the mandatory google javascript in the footer and it is there.

    What is the solution to this problem?

Viewing 8 replies - 1 through 8 (of 8 total)
  • I have the same problem. Tried setting up SMTP – that didn’t work either.
    Does anyone have a solution to this?

    Same here.

    Authentication is correct too.

    Same for me. ALL websites fail to send message. I have had to revert to v5.0.5.

    What I noticed is the Google URL to the recapcha seems to have a small issue.
    &ver=3.0
    Where &#038 ; is a & but all other scripts have their version added with a “?”
    However, removing the version completely doesn’t seem to help.
    I will continue looking for a fix.

    • This reply was modified 9 months, 2 weeks ago by  .

    I think I found the source of the problem:

    Uncaught Error: Invalid site key or not loaded in api.js: 6L**********************************************
    at Object.zP [as execute] (recaptcha__nl.js:504)
    at HTMLDocument.execute ((index):1311)
    at Object.wpcf7.triggerEvent (scripts.js?ver=5.1.1:367)
    at ajaxSuccess (scripts.js?ver=5.1.1:298)
    at Object.<anonymous> (scripts.js?ver=5.1.1:350)
    at i (jquery.js?ver=1.12.4:2)
    at Object.fireWith [as resolveWith] (jquery.js?ver=1.12.4:2)
    at y (jquery.js?ver=1.12.4:4)
    at XMLHttpRequest.c (jquery.js?ver=1.12.4:4)

    I received the keyset but it might be that the domain was not listed in Google captcha. I will have to check this out before I can continue.

    • This reply was modified 9 months, 2 weeks ago by  .

    @onepack – I could be wrong but your error looks like you simply have not authenticated correctly with Google reCAPTCHA on this particular site.

    It works now I have looked at the google account. I seems they (clients) provided me with the wrong keys. It works now! The error is gone.
    So if you have a similar javascript error it is related to a wrong key-pair or domain in the google settings.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Forms cannot be submitted since 17 december’ is closed to new replies.