Support » Plugin: WooCommerce Deutsche Post Internetmarke » Fehler beim Label-Download.

  • Hallo,

    nachdem eine Versandmarke über die Portokasse bezahlt wurde, lässt sich das Label nicht downloaden. Es öffnet sich lediglich ein neuer Tab mit der Sendungen Seite und der Fehlermeldung “Fehler beim Label-Download.”.
    Leider lässt sich nirgends etwas Genaueres herausfinden. In den Logs ist nichts zu finden.

    Versucht man über das Dropdown Menü unten links das Herunterladen (.zip) oder (.pdf), dann wird ein Download getriggert. Leider ist die Zip dann 0 kb groß und lässt sich nicht öffnen, die PDF Datei ist einfach leer.

    Was können wir tun?
    Vielen Dank im Voraus.

    Edit: Scheinbar hat auch die Bezahlung nicht funktioniert. Der Kontostand der Portokasse ist unverändert.

Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Support Drazen Bebic

    (@drazenbebic)

    Hallo @skinperforator,

    vielen Dank für Ihre Nachricht und die Nutzung unseres Plugins.

    Wir hätten noch ein paar Fragen, sodass wir das Problem besser verstehen und nachvollziehen können, und zwar:

    • War dies in “normales” Label, oder ein Harmonized Label?
    • Haben Sie den Logger zuvor aktiviert?
    • Gibt es Log-Einträge unter “Internetmarke – Settings – Tools – Logging”?

    Falls es der Logger nicht aktiv war, würden wir vorschlagen, dass Sie den Logger aktivieren und es erneut versuchen. Daraufhin müsste irgendeine Art von Log-Eintrag beim Fehler generiert werden.

    Falls er doch aktiv war, und es trotzdem keine Log-Einträge gab, würde ich Sie bitten uns Ihre PHP Error Log Datei zukommen zu lassen.

    skinperforator

    (@skinperforator)

    Hallo,

    Es war ein Harmonized Label.

    Das Logging habe ich leider erst danach aktiviert. Dort sind noch keine Einträge zu finden. Nun kann ich diese Bestellung aber auch nicht noch einmal versuchen, da dort alle Artikel schon als bearbeitet drin sind. Der Button “Etikett Rückerstattung…” zeigt keine Wirkung, auch keinen Log-Eintrag. Gibt es eine Möglichkeit, die Artikel wieder zurück zu setzen?

    Im allgemeinen Fehler-Log sind nur mehrere der folgende Einträge für das Plugin zu finden (diese decken sich allerdings von der Zeit her nicht mit der Erstellung der oben genannten Marke):

    2019-09-19T10:33:17+00:00 CRITICAL Uncaught SoapFault exception: [soap:Server] No product with code: 0 found! in /home/www/wp/wp-content/plugins/woo-dp-internetmarke/includes/connectors/soap/OC4A.php:249
    Stack trace:
    #0 /home/www/wp/wp-content/plugins/woo-dp-internetmarke/includes/connectors/soap/OC4A.php(249): SoapClient->__soapCall('retrievePreview...', Array)
    #1 /home/www/wp/wp-content/plugins/woo-dp-internetmarke/includes/components/DPShop.php(371): WCDPI\Connectors\SOAP\OC4A->retrievePreviewVoucherPng(0, 'AddressZone')
    #2 /home/www/wp/wp-includes/class-wp-hook.php(286): WCDPI\Components\DPShop->previewVoucher('')
    #3 /home/www/wp/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters('', Array)
    #4 /home/www/wp/wp-includes/plugin.php(465): WP_Hook->do_action(Array)
    #5 /home/www/wp/wp-admin/admin-ajax.php(173): do_action('wp_ajax_wcdpi_p...')
    #6 {main}
      thrown in /home/www/wp/wp-content/plugins/woo-dp-internetmarke/includes/connectors/soap/OC4A.php in Zeile 249

    Also trotz aktiviertem Logging gibt es dort keine Einträge. Ein neuer Versuch hat zum gleichen Ergebnis geführt -> Kein Abbuchen aus der Portokasse, Sendung ‘versandbereit’ und ‘Fehler beim Label-Download.’

    Plugin Support Drazen Bebic

    (@drazenbebic)

    @skinperforator

    No product with code: 0 found!

    Aus irgendeinem Grund, übergibt Ihr Plugin der Schnittstelle eine 0 als product code, was es nicht gibt. Der product code ist sozusagen die ID welches das Versandprodukt gegenüber der Schnittstelle der Deutschen Post identifiziert.

    Haben Sie eventuell einen Test-Server wo wir uns das Problem vor Ort ansehen könnten? Weitere Einträge aus der PHP Error Log Datei würden uns auch möglicherweise weiterbringen.

    Ich denke, dass die Meldungen nicht unbedingt etwas mit dem aktuellen Problem zu tun haben, da sie vom Zeitstempel her nicht mit den Labelerstellungen übereinstimmen. Wahrscheinlich sind sie eher aus der Zeit, wo das Plugin noch nicht richtig konfiguriert war.

    Im Error Log findet sich als einziges noch Folgendes:
    PHP Warning: Invalid argument supplied for foreach() in /home/www/wp/wp-content/plugins/woo-dp-internetmarke/includes/admin/MetaBoxes.php on line 746

    Zum Zeitpunkt des versuchten Label-Downloads wird jedoch auch dort gar kein Fehler ausgegeben.

    Wir haben, zum Glück, selbst keine derartigen Probleme. Die Deutsche Post eFiliale scheint allerdings momentan auch Probleme mit der Labelerstellung zu haben:

    https://www.trustpilot.com/review/www.efiliale.de?languages=all&fbclid=IwAR1SOE97JLwjOb0Am_DLRTncxRaX36NTRanKaVEGwz65jXGwV1gcZTBzILQ

    Vielleicht hängt das ja zusammen..

    Wenn dem so wäre, hätten dann nicht alle Nutzer des Plugins das Problem?

    Plugin Support Drazen Bebic

    (@drazenbebic)

    @skinperforator,

    ist dieses Problem auf eine Bestellung begrenzt, oder funktioniert es bei jeder Bestellung nicht? Konnten Sie bis jetzt überhaupt ein Harmonized Label über das Plugin generieren?

    Nein, es lässt sich überhaupt kein Label generieren. Bei jeder Bestellung das gleiche Problem.

    Ich wollte heute meine erste Bestellung versandfertig machen und ich habe das gleiche Problem.
    Alle möglichen Links und Buttons (“Etikett kaufen”, “Sendung erstellen”, “Versandprodukte kaufen”, …) bewirken gar nichts. Nirgendwo kann man das Label downloaden oder die Bestellung weiter bearbeiten.

    Plugin Support Drazen Bebic

    (@drazenbebic)

    @skinperforator, @schneeamsel

    Haben Sie bereits Ihre EKP Nummer in die Einstellungen eingetragen? Dies könnte zu diesen Problemen führen.

    skinperforator

    (@skinperforator)

    Also die EKP Nummer war noch nicht eingetragen und ist nun aber drin und es ergibt sich folgendes Verhalten:
    – EU, Harmonized Label -> Fehler bleibt wie gehabt, kein Download möglich, keine Abbuchung
    – EU, kein Harmonized Label -> funktioniert
    – Nicht-EU, kein Harmonized Label -> funktioniert (aber ohne Zollinhaltserklärung, nicht brauchbar)

    Ergo funktioniert die Harmonized Label Funktion, die aber für Bestellungen außerhalb der EU und demnächst sowieso wichtig wäre, nicht.

    Plugin Support Drazen Bebic

    (@drazenbebic)

    @skinperforator,

    haben Sie vielleicht einen Test-Server wo wir uns das Problem ansehen könnten? Ich vermute, dass das ewige hin- und herschreiben nicht viel bringen wird. Am besten wäre es, wenn wir uns das direkt bei Ihnen im System ansehen könnten.

    Wie kann ich Ihnen denn den Zugang zukommen lassen?

    Plugin Support Drazen Bebic

    (@drazenbebic)

    @skinperforator

    Bitte eine E-Mail an die support@stina-global.com schreiben.

Viewing 15 replies - 1 through 15 (of 18 total)
  • You must be logged in to reply to this topic.