Support » Plugin: 3CX Free Live Chat » Failed to load SourceMap

  • Resolved danbooth

    (@danbooth)


    I’m seeing the following error in console in Chrome:

    DevTools failed to load SourceMap: Could not load content for https://www.mysite.co.uk/wp-content/plugins/wp-live-chat-support/js/vendor/bootstrap/dist/js/bootstrap.bundle.js.map: HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE

    It happens in Firefox too.

    The error only happens when in when in the WordPress dashboard, not on the front end.

    I came across this when investigating an error which may or may not be related to this. My client (the website owner) said LiveChat didn’t ring when someone was trying to message them. They only knew about it when they received an email notification.

    I’ve since tested LiveChat and it seems to be working fine, but I’m interested to know more about the SourceMap issue. Is this something serious and how should go I about fixing it?

    Some more info…

    Wordpress 5.3.3
    LiveChat 8.1.7

    The theme is Divi.

    Any advice would be much appreciated.

    Thanks,
    Dan

    • This topic was modified 2 years, 2 months ago by danbooth.
    • This topic was modified 2 years, 2 months ago by danbooth.
Viewing 15 replies - 1 through 15 (of 22 total)
  • Hi there; same thing is happening to one of my sites. I have also installed Divi and, in fact, this error isn’t letting me work in the Visual Editor. It’s the first time this happens to me since i’ve worked with this theme for almost 4 years.

    /wp-content/themes/Divi/includes/builder/frontend-builder/build/theme-builder.js.map
    /wp-content/themes/Divi/includes/builder/scripts/cpt-modules-wrapper.js.map

    Hi!

    Same problem here. Have the same error on ALL my Divi pages – and one page pagebuilder does not not work.

    Same. Cannot use Divi Builder in Chrome, Edge, Brave, Firefox.
    All errors are on loading content for Divi themes.

    “failed to load SourceMap” is a warning, and it’s non-fatal: it should not cause problems. It just means it can’t find an un-minified version of the script, so you won’t see the original code in the debugger.

    The Divi Builder fails to load in one of my sites too, and I’m hunting down the error. It worked just fine a couple of days ago, not sure what changed, but now I get this error:

    bundle.js?ver=4.3.1:formatted:29366 Uncaught TypeError: Cannot read property 'wp' of undefined

    which refers to:

    function(e, t) {
        e.exports = window.et_gb.wp.hooks
    }

    Do you guys see this error too?

    Update: as a workaround, I got it to work by adding

    <script type="text/javascript">
    window.et_gb = (window.top && window.top.Cypress && window.parent === window.top && window) || (window.top && window.top.Cypress && window.parent !== window.top && window.parent) || window.top || window;
    </script>

    to my pages (in Divi > Theme Options > Integration > Add code to the head, for example).
    This should be added by includes/builder/functions.php:et_fb_enqueue_bundle(), but it’s not happening for some reason (some particular Divi setting on this particular server, perhaps).

    Thread Starter danbooth

    (@danbooth)

    Thought I’d best chip in as the original poster.

    I see there a few of you with SourceMap issues – all relating to Divi Builder. Divi actually works fine for me.

    My SourceMap error relates to WP Live Chat and a Bootstrap file it’s trying to load.

    From what @chemaz has said, it’s sounds like it is fairly innocuous in my case. It doesn’t seem to be causing any problems for my site. I was really just interested to know if this was something to worry about – it seems not.

    Hope you all manage to fix your Divi issues.

    intechra

    (@intechra)

    The code @chemaz posted didn’t work for me. I’m wondering if there’s another workaround. Would like to clear this warning, even if isn’t fatal, so as to eliminate possible causes for other issues I’m debugging.

    ChemaZ

    (@chemaz)

    @intechra: Read again please.
    My code has *nothing* to do with the SourceMap warning. Which in turn is completely harmless. It just means Dev Tools can’t find the original source of a script, even though the script has a source map declaration.
    To remove it, you either eliminate the sourceMappingURL=foo.js.map statement from said script (or whatever creates it, rather), or disable source maps in your Dev Tools.
    Or the easiest way: just ignore it. (Elegant should take care of it any time now 🙂

    Fotis

    (@kokkoras)

    same problem here (with Divi theme)

    DevTools failed to load SourceMap: Could not load content for http://live.rdn1.com/wp-content/themes/Divi/js/custom.unified.js.map: HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE
    DevTools failed to load SourceMap: Could not load content for http://live.rdn1.com/wp-content/themes/Divi/includes/builder/frontend-builder/build/boot.js.map: HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE
    DevTools failed to load SourceMap: Could not load content for http://live.rdn1.com/wp-content/themes/Divi/includes/builder/frontend-builder/assets/scripts/failure_notice.js.map: HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE
    Why these errors are happening in suing Divi theme?

    I wish anybody can help me

    Same here… Does someone resolved yet?

    • This reply was modified 1 year, 10 months ago by Fred Fontes.

    Just purchased Divi last night. Builder works great. But when I view my created design in my browser outside of the builder all Divi elements are missing.

    Spent hours building a nice design just to have pretty much a blank page when it’s viewed.

    Started looking for issues and found:

    Source map error: Error: request failed with status 404
    Resource URL: http://192.168.0.81/wp-content/themes/Divi/js/custom.unified.js?ver=4.6.1
    Source Map URL: custom.unified.js.map

    Makes sense that the page is mostly blank if the unified js won’t load.

    I’ll probably just get my money back and move on to a different builder. I really don’t have time to waste on something that doesn’t work.

    @designtimestudio The message you are seeing is a warning only and has nothing to do with why your problems with seeing a blank page. It is simply a warning displayed by your browsers debugger that it can’t see a debug file it can use to show more information in your browsers debugger.

    If you are still having issues, you might want to raise a ticket with Divi Support directly. Have you disabled caching and minification during debugging?

    It because Chrome added support for source maps. Yes it’s just a Warning, but it’s annoying, i found a solution I like on Stack, just give it what it wants, in my case it was asking for a .map file for gmaps.min.js.

    so i added a gmaps.min.js.map file at the requested location, with this content;

    `{
    “version”: 1,
    “mappings”: “”,
    “sources”: [],
    “names”: [],
    “file”: “gmaps.min.js”
    }

    and no more nagging warning, just do the same for you warning(s) and don’t forget to change the filename in de json and problem solved.

    But still ask the extension provider, to include source map file(s) in there extension, it simple for them to add one in the build process.

    Succes

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘Failed to load SourceMap’ is closed to new replies.