• Resolved Fionavar

    (@fionavar)


    Warning: file_put_contents(/home/content/p3pnexwpnas12_data02/78/3762778/html/wp-content/plugins/rvg-optimize-database/logs/rvg-optimize-db-log.html): failed to open stream: No such file or directory in /home/content/p3pnexwpnas12_data02/78/3762778/html/wp-content/plugins/rvg-optimize-database/classes/odb-logger.php on line 74

    Warning: file_put_contents(/home/content/p3pnexwpnas12_data02/78/3762778/html/wp-content/plugins/rvg-optimize-database/logs/rvg-optimize-db-log.html): failed to open stream: No such file or directory in /home/content/p3pnexwpnas12_data02/78/3762778/html/wp-content/plugins/rvg-optimize-database/classes/odb-logger.php on line 95

    Please Advise?

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author cageehv

    (@cageehv)

    Hey Fionavar,

    Does the log directory (/wp-content/plugins/rvg-optimize-database/logs/) exist on the server?
    If yes, what are the permissions of that folder?

    peace,
    Rolf

    There is not such folder Rolf

    Plugin Author cageehv

    (@cageehv)

    Hey Fiona,

    Okay, thanks for checking.
    In that case creating the directory apparently is the issue…

    Must be some server setting.
    You could try to create the folder yourself.

    Rolf

    Okay – with what permissions?

    Plugin Author cageehv

    (@cageehv)

    Errr… 770 or so (just as a test)

    Plugin Author cageehv

    (@cageehv)

    411 also should be enough:
    owner: read + write
    group: read
    other: read

    Okay created directory with 411 setting and still received this:

    Warning: file_put_contents(/home/content/p3pnexwpnas12_data02/78/3762778/html/wp-content/plugins/rvg-optimize-database/logs/rvg-optimize-db-log.html): failed to open stream: Permission denied in /home/content/p3pnexwpnas12_data02/78/3762778/html/wp-content/plugins/rvg-optimize-database/classes/odb-logger.php on line 74

    Warning: file_put_contents(/home/content/p3pnexwpnas12_data02/78/3762778/html/wp-content/plugins/rvg-optimize-database/logs/rvg-optimize-db-log.html): failed to open stream: Permission denied in /home/content/p3pnexwpnas12_data02/78/3762778/html/wp-content/plugins/rvg-optimize-database/classes/odb-logger.php on line 95

    Plugin Author cageehv

    (@cageehv)

    Pffffhhhh… I have no idea… 🙁

    This never caused problems before. At least, no one reported a problem about this.
    Just tested it again myself and the log file is being created without any problems.

    I have no idea what else you could try. It clearly states it’s a ‘Permission denied’ error.

    Okay – but the plugin seems to be working others wise. Should I choose ‘executable’ as an option under Owner?

    Plugin Author cageehv

    (@cageehv)

    Not necessarily… My setting is 411 and it works fine.
    You can try anyways!

    Got it – copied setting from JEtPack Logs /dir = 705

    Plugin Author cageehv

    (@cageehv)

    So, it works now?

    Yep – well it was working – just no errors now

    Plugin Author cageehv

    (@cageehv)

    Okay, cool!

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Error’ is closed to new replies.