Support » Plugin: Elementor Custom Skin » Elementor Style Tab broken

  • With the latest version of Elementor, enabling this plugin disables the style tab for all widgets. Disabling the plugin gets it working again.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Same here! when activating ele custom skin, the editor tab from elementor (pro) disapear.
    Please update.. its a major bug!
    thank you

    same here, plugin not working with latest Elementor update.

    @duke78 I get the same issue.

    I fixed it by myself, thanks.

    Thread Starter jordanwebdev

    (@jordanwebdev)

    @hoosoft That’s great! Mind sharing the solution?

    @jordanwebdev

    There are 2 methods:
    1, Rollback elementor 3.7.x to elementor 3.6.8

    2, Modify Elementor Custom Skin php files

    change all elementor/widgets/widgets_registered to elementor/widgets/register

    change code

    public function init_widgets() {
    
    		// Include Widget files
    		require_once( __DIR__ . '/widgets/loop-item.php' );
    
    		// Register widget
    		\Elementor\Plugin::instance()->widgets_manager->register_widget_type( new \Ele_Custom_Loop_Item_Widget() );
    
    	}

    to

    public function init_widgets($widgets_manager) {
    
    		// Include Widget files
    		require_once( __DIR__ . '/widgets/loop-item.php' );
    
    		// Register widget
    		$widgets_manager->register( new \Ele_Custom_Loop_Item_Widget() );
    
    	}
    • This reply was modified 3 months, 2 weeks ago by HooThemes.
    • This reply was modified 3 months, 2 weeks ago by HooThemes.

    Still broken in 3.1.7.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.