Support » Plugin: Widget Shortcode » edit shortcode

  • Resolved kb1234

    (@karenbatten)


    Hi There,
    I’m editing a website that i didn’t create.
    Whenever I go to create some text for the widget this appears
    Shortcode: Please save this first… where do i save the shortcode?
    I just want to add text in another widget… I’ve search for videos on how to use this plugin but haven’t found anything to help.
    Thanks in advance.

    The page I need help with: [log in to see the link]

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author shazdeh

    (@shazdeh)

    Hi!

    The way the plugin works is, you go Appearance > Widgets and drop some widgets in the “Widget Shortcode” area, then the shortcode appears and you can copy-paste that anywhere to display that widget.
    The “Please save this first” message appears when first you drop a widget, it just says that you need to save the widget (the blue Save button, see screenshot: https://ps.w.org/widget-shortcode/assets/screenshot-1.png?rev=947278), after you save the shortcode will appear.
    Hope this helps!

    kb1234

    (@karenbatten)

    thanks heaps for your help. Unfortunately i’m still confused.

    The current footer pages has ‘acknowledgement’ text which is [widget id=”text-3″]… if i wanted to edit ‘text-3’ where would i find that? Maybe then I’ll understand how to create this text for the other footer area…

    if i move the text widget into the widget shortcode area it says ‘shortcode: please save this first’ and i can’t press the {saved} button. which is the same thing that happens if I put it in footer area #3.

    thanks so much in advance.

    Plugin Author shazdeh

    (@shazdeh)

    All widgets are in Appearance > Widgets, that’s where you edit your widgets.

    What this plugin does is, it enables you to use that widget elsewhere in your site. So, in your footer you have the “Acknowledgement” text widget which has the [widget id="text-3"] shortcode, right? Now you can paste that shortcode in a page’s contents or in your sidebar or anywhere (where shortcodes work) and that widget will appear there. The plugin does not change how you edit your widgets however, they are still managed in the Appearance > Widgets admin screen.

    kb1234

    (@karenbatten)

    usually when i edit widgets i just drag ‘text’ or whatever widget is required into the ‘footer area #3’ or whatever area is required and edit there. Now I see a shortcode ‘widget id=”text-3″ and no place to edit the text.

    Where is the text 3 so that i can edit it?
    This might help me understand how to create the content for a new footer area…
    Thanks again…

    kb1234

    (@karenbatten)

    When i try and start a new ‘text’ widget under the footer it appears with ‘Shortcode: Please save this first.’ but the is no option to save widget as the save button is greyed out and says ‘{saved}’. Please any help would be great?

    Plugin Author shazdeh

    (@shazdeh)

    Can you please provide an screenshot of your Widgets admin page with all the areas (on the right side of the screen) expanded? Similar to this screenshot: http://ovo.li/83cR6S?

    kb1234

    (@karenbatten)

    http://ovo.li/uploads/fRMtdF
    thanks so much for continuing to help me…

    Plugin Author shazdeh

    (@shazdeh)

    Oh I see the issue now. Something is wrong there! First step, go to Appearance > Themes and change to a core theme (like Twenty Seventeen) then check if the issue is still there. If it is, try going to Plugins admin page and disable all your active plugins (including the Widget Shortcode) and then check the issue.

    You can revert the changes later, the above steps however can determine what is causing the issue in the first place.

    kb1234

    (@karenbatten)

    thanks you so so so much!!!!
    I changed theme then went back to my original theme and the error stopped. thanks again.

    Plugin Author shazdeh

    (@shazdeh)

    Happy to help!

    kb1234

    (@karenbatten)

    i’ve been using divi theme with widget shortcode plugin, we just migrated the site to a new server and this error has appeared the same as above but it’s not resolving using the same method as above.

    I change to to 2017 theme and the plugin works fine…
    … do you have any suggestions?

    Plugin Author shazdeh

    (@shazdeh)

    Hi,

    Can you please describe what is the issue exactly?

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘edit shortcode’ is closed to new replies.