Support » Plugin: WP Statistics » E-mail setup issues and no e-mail..

  • Resolved turquise1

    (@turquise1)


    Hi there,

    The plugin looks good and seems to report accurately but I just cannot activate the e-mail notice functionality.

    First, when I try to set the notice frequency setting to ‘once daily’, after I click on update the option comes back as ‘Please select’. When I choose ‘once hourly’ after the update button press, it comes back as ‘twice weekly’. When I switch to Cron to see the schedule I see it as (report_hook?) once daily (That does not change even after I change my settings on WP Statistics) but I never get the e-mail.

    Our system is running on ‘PageLines’, not sure if that would affect anything.

    Please advise,

    Thanks..

    https://wordpress.org/plugins/wp-statistics/

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Contributor Greg Ross

    (@gregross)

    The display of the current schedule has a bug, to fix it, edit wp-statistics/includes/settings/tabs/wps-general.php, line 318 should currently be:

    echo '					<option value="' . $key . '" ' . selected($WP_Statistics->get_option('time_report'), 'hourly') . '>' . $value['display'] . '</option>';

    change it to:

    echo '					<option value="' . $key . '" ' . selected($WP_Statistics->get_option('time_report'), $key) . '>' . $value['display'] . '</option>';

    As for the delivery of the mail, since you can see the cron job it’s running, make sure your WordPress install can send mail through wp_mail.

    Thanks for the fix on that, but I still have other issues.

    When I change the frequency of notice to Once Hourly on WP-Statistics, I still see Once Daily (Is it report_hook that I am supposed to look at?) in Cron. That does not seem to change.

    Can that be changed manually?

    I have not looked into the e-mail situation yet but is there way to see if its denied by my server, or stuck somewhere?

    Thank you..

    Ozzie

    Also,

    I have just tested my wp_mail functionality and I receive e-mails to the address I use promptly, so that part seems to work.

    Thanks,

    Ozzie

    Plugin Contributor Greg Ross

    (@gregross)

    Try disabling reports, saving the option (the report_hook cron entry should be deleted) and then re-enabling it.

    Have you configured a different address to send mail to than the blog admin?

    I have installed something called a Crontrol plugin. After I erased the cron entry (report_hook) from there, it actually came back as 1 hour (which is the correct setting). I tried to run that entry (the plugin lets me) but I did not see an e-mail yet (checking my spams as well)

    I am using the same e-mail address on both (blog admin and wp statistics)

    Any other suggestions?

    Ozzie

    Here are the options I checked..

    Statistical Reporting – Active
    Schedule – Once Hourly
    Send Reports – Via Email
    E-mail addresses : my e-mail address
    Report Body (I am suspecting I may be making a mistake here? This is empty right now, Do I add anything here? I am thinking there is a default setting for this area but not sure..)

    Ozzie

    Plugin Contributor Greg Ross

    (@gregross)

    Yes, you have to add in text with short codes (see the manual for details) otherwise no e-mail will be sent.

    This is what I have in there right now and I still do not get any e-mails..

    [wpstatistics stat=\”pagevisits\” time=\”total\” provider=\”google\”]

    Also when I look at the Cron Management plugin (Crontrol), I see Arguments as just [] (just trying to give you more details).

    Is there a file to look at to see if everything is in place correctly?

    Thanks,

    Ozzie

    Plugin Contributor Greg Ross

    (@gregross)

    Remove the quotes around the parameters so:

    [wpstatistics stat=pagevisits time=total provider=google]

    Plugin Contributor Greg Ross

    (@gregross)

    Found a bug in the code, edit schedule.php in the root of the plugin, line 135 should be:

    $string = $WP_Statistics->get_option('content_report');

    change it to:

    $final_text_report = $WP_Statistics->get_option('content_report');

    Ok, now it is sending reports.

    You have been very helpful,

    Thank you..

    Plugin Contributor Greg Ross

    (@gregross)

    No problem, the next release will include both fixes.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘E-mail setup issues and no e-mail..’ is closed to new replies.