Support » Plugin: WP Easy Columns » Doesn't work on subdomain?

  • Have been using v2.1 without any problems, and just upgraded to 2.1.1. Now I can’t seem to get the plugin to work. It displays a popup screen, but nothing is clickable. Looked at the console, and it threw out some errors:
    Blocked a frame with origin “http://www.xyz.me.uk” from accessing a frame with origin “http://y.xyz.me.uk”. Protocols, domains, and ports must match. tiny_mce_popup.js:5
    Uncaught TypeError: Cannot read property ‘EditorManager’ of undefined tiny_mce_popup.js:5
    Uncaught TypeError: Cannot read property ‘windowManager’ of undefined mctabs.js:13
    Uncaught TypeError: Cannot read property ‘baseURI’ of undefined form_utils.js:11
    Uncaught TypeError: Cannot call method ‘add’ of undefined tiny_mce_popup.js:5

    I’m in a wordpress site in y.xyz.me.uk (so y is a subdomain)

    Have just tried it on a different site (non subdomained, with exactly the same plugins) and 2.1.1 works on there.

    I shouldn’t be blaming the plugin, but just wondering if its to blame or something else?

    Thanks,
    Chris

    http://wordpress.org/plugins/easy-columns/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Edit: Ooh, looks like its a Chrome issue. Nice. :sigh:
    It mentions about cross-domain-ness – the plugin belongs to the ‘root’ domain, but I’m using it in a subdomain. Guess thats the end of Easy Columns for me then?

    Plugin Author Pat Friedl

    (@kcfried)

    Hmmm, that may be an issue with the tinyMCEpop up window. Could you email me directly? If you don’t mind, I’d like to login and reproduce the issue myself so I cam debug a little and see about a fix.

    Next update, I’ll be using the ThickBox pop up instead of the tinyMCE window – much easier to handle that way.

    Gladly… if I could find an email address… Looked here:
    http://profiles.wordpress.org/kcfried/

    but it didn’t list anything. Found your site, but under ‘contact me’ it said I had to register first… want me to do that?

    Plugin Author Pat Friedl

    (@kcfried)

    Yeah, sorry about that – haven’t had time to add a contact page or much content. Get me at pfriedl _at_ gmail.com.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Doesn't work on subdomain?’ is closed to new replies.