• OllyDowning

    (@ollydowning)


    Hi Matt,

    Trying to use a Font Awesome field in an ACF repeater in a Divi Machine block, this uses a divi template to output in this case an icon and a title as a button.

    The problem is for some reason the output, no matter what I seem to do, is null. The module itself is output but the content is empty. I have tried changing a number of settings with no luck, just wondered if you have any ideas?

    Thanks!

Viewing 8 replies - 1 through 8 (of 8 total)
  • John

    (@jhob)

    Sorry, I don’t have any ideas, but I’m also experiencing the same issue.

    Would love a solution to this!

    Plugin Author Matt Keys

    (@mattkeys)

    Hello,

    I’m happy to take a look at this but I’m not particular familiar with Divi Machine blocks. If the underlying theme and or plugin(s) are something you are authorized to share with me, I’ll take a look. I’m not asking for access to your environment ( a no-no on these forums ). Just access to the theme and or plugin needed to recreate the problem you are seeing. And any steps/instructions to recreate the issue. Feel free to reach out to me on the WordPress slack channel or through my site contact form: https://mattkeys.me/

    John

    (@jhob)

    I contacted Divi Machine support about this and they weren’t especially helpful. So I took a look myself and I think I’ve worked out how to make it work. Very simply add this to the end of functions.php:

    add_filter('divi_machine_basic_acf_types', 'add_font_awesome_type_to_divi_machine', 10, 1);
    
    function add_font_awesome_type_to_divi_machine($types) {
    	$types.= ', font-awesome';
    	return $types;
    }

    I’ve not tested it extensively but I’m pretty confident it will work without issue.

    Plugin Author Matt Keys

    (@mattkeys)

    Thanks for sharing @jhob !

    John

    (@jhob)

    No probs, hope it helps someone!

    John

    (@jhob)

    @mattkeys I have spotted what I think is a bug in the plugin though.

    If a default icon is specified then this getting returned even when a different icon had been selected and saved in the acf field.

    Removing the default image in the field group resolves the issue, and the set icon is returned.

    Additionally in the field group editor the ‘x’ cannot be clicked to remove the default icon as it is behind the down chevron to expand the icon search. My workaround was to delete the chevron in chrome dev tools which allowed me to be able to click the ‘x’ to remove the default icon.

    Hope that helps

    John

    Plugin Author Matt Keys

    (@mattkeys)

    Hey John,

    I’m not able to reproduce the default icon bug you mention. Are you only seeing this bug while working within the ‘Divi Machine’ or outside of that use case as well?

    I do see what you mean about the hard to press ‘clear’ icon. Strange as none of that CSS comes from my plugin, the problem must be somewhere between the default Select2 CSS and any overrides/themes that ACF is loading for it. I was still able to click it but only at the ‘bottom’ of the X icon. I am hesitant to try and resolve this within my plugin as I think it needs to be fixed in ACF, but if it doesn’t resolve itself by the next release of this plugin I’ll see if there is something I can do.

    John

    (@jhob)

    @mattkeys I’ve not tried it outside of Divi Machine, although it didn’t seem to me that it would be related to that. I’ll test tomorrow anyway without Divi Machine and see if I can replicated.

    It was in a repeater (ACF Pro), not sure if that makes any difference.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Divi Machine’ is closed to new replies.