WordPress.org

Support

Support » Plugins and Hacks » Custom Post Type UI » [Resolved] Custom Post Type UI – Menu Error

[Resolved] Custom Post Type UI – Menu Error

  • Plugin Edition: Custom Post Type UI v0.7.2

    I’ve been using this plugin for quite some time on numerous sites. However, I’m working on one now that’s giving me a bit of trouble.

    I was able to setup the Taxonomies the same way I always do, and created the categories for each custom post. However, when attempting to add the categories to a WP Nav-Menu I’m being told that the links are invalid. Everything is setup exactly as I’ve done in the past and never experienced a problem.

    Is there anything anyone can do to help? I’ve removed the custom post type all together (via plugin/database) and recreated (via the plugin) and am still experiencing issues.

    Is this a common bug with this version? The category pages themselves (when going back into them and clicking “View”) work just fine. It’s just not allowing me to add them to the menu and I can’t add them as a custom link because of the CSS options (set by client).

    HELP!

    http://wordpress.org/extend/plugins/custom-post-type-ui/

Viewing 8 replies - 1 through 8 (of 8 total)
  • To clarify – When adding the category to the menu the box shows pink and just says “Invalid”, upon some edits I was able to actually get the title to load but upon saving all it tells me is: There are some invalid menu items. Please check or delete them.

    I was able to fully resolve this on my own with a full reinstall of WordPress.

    Hi Krissy

    I have the same issue. I tried a reinstall of the core WP files. What did you do exactly?

    Thanks in advance

    @get-carter

    I was only able to get this to work by reinstalling WordPress. There were no other ‘tricks’ involved. It was a corrupted database on WordPress’ part from what I could see. A complete reinstall where I saved the wp_posts table was all that was needed.

    Hope this helps.

    Plugin Author Michael Beckwith

    @tw2113

    Glad to hear you got what you needed, done, Krissy

    Plugin Author Michael Beckwith

    @tw2113

    Get-Carter, did you ever get yours figured out?

    Another issue that I’m dealing with at the moment is the Meta box is not available under the Menu’s for any of the post-types created (even though there are archives for each post type in the database).

    How would I go about fixing this without completely reinstalling EVERYTHING all over again? Running most recent versions of WP and this plugin.

    Disregard – for some reason the screen options weren’t enabled.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] Custom Post Type UI – Menu Error’ is closed to new replies.
Skip to toolbar