Support » Plugin: Custom Post Type UI » Category not showing custom posts

  • Resolved iantresman

    (@iantresman)


    I’ve assigned a core category to a custom post type, but when I click the category, it is not showing the posts associated with it.

    I’ve read the post “How to add your new post type to WordPress category and tag archives“, and used the “Code Snippets” plugin to add the code.

    Looking at my custom post type, on the Registered Types and Taxonomies page, taxonomies correctly shows “Categories”. I have also enabled Has Archives.

    I’m using GeneratePress as my theme. Will I need to add something to my GeneratePress theme?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Michael Beckwith

    (@tw2113)

    The BenchPresser

    What’s the URL you’re trying to accomplish this at? If it’s just a page that is meant to show an archive via some sort of shortcode or module from GeneratePress, then chances are the doc page you linked to above isn’t going to have any effect.

    Typically, the actual term archive is going to be something like https://www.MYSITE.com/category/someterm or https://www.MYSITE.com/tag/someterm

    Thanks for the pointers. Might be a URL issue. I just added a couple of regular posts and core categories, and they are not appearing either. My category URLs are showing as just /mysite.com/cat01/ and /mysite.com/category/cat01/ doesn’t work either. Am investigating. Thanks for your reply.

    Plugin Author Michael Beckwith

    (@tw2113)

    The BenchPresser

    Any new information or progress made here?

    I haven’t been able to take another look, but when I do, I’ll post any solutions here that I find. Thanks for following up.

    Now resolved. In Settings|Permalinks, I had the Category base set to “.” effectively removing the category base. On restoring the category base to “category”, and click a category, all the associated posts appeared.

    Plugin Author Michael Beckwith

    (@tw2113)

    The BenchPresser

    Good to hear this got figured out. Thanks for the followup.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.