Support » Plugin: OPcache Manager » Analytics empty

  • mmwbadmin

    (@mmwbadmin)


    Hi,
    OPCache Analytics (Zend OPcache 7.4.7) is empty, while OPcache Management displays > 850 files (with some hits).
    I would expect them to show up in PerfOps Analytics OPcache, but Hit Ratio through Buffer Saturation = 0, Availability = 100%.
    Am I missing something?

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 29 total)
  • Plugin Author Pierre Lannoy

    (@pierrelannoy)

    Hello!
    The issue you have may be due to two distinct causes:
    – your website is hosted on a shared environment and the hoster (your provider) had disabled the OPCache query (unlikely).
    – your cron job is not fully operational (very likely).

    I suggest to investigate second possible cause first: has your website a specific cron job (do you have done / installed something special or is is just the standard WordPress cron)?

    Thread Starter mmwbadmin

    (@mmwbadmin)

    Hi,
    if I switch the OPcache PHP extension off and back on, it’s shown in OPcache Analytics in the “Status Events” panel.

    Using just plain WP cron. In WP Crontrol I see several cron jobs, amongst which one on hook opcm_opcache_stas that runs OPcacheManager\Plugin\Feature\Capture::check()

    Running on LSWS with Redis object cache.

    Plugin Author Pierre Lannoy

    (@pierrelannoy)

    Ha! Thanks for this details.
    It may come from Redis, can you tell me what specific plugin you use for Redis?

    Thread Starter mmwbadmin

    (@mmwbadmin)

    Hi,
    activated as object cache in LiteSpeed Cache plugin for WP (WP companion for sites on LiteSpeed Web Server).

    Plugin Author Pierre Lannoy

    (@pierrelannoy)

    Thanks.
    I will get an eye on this plugin during weekend. Maybe am I calling it wrongly in OPcache Manager.

    I will back to you as soon as I have news – or questions πŸ˜‰

    Thread Starter mmwbadmin

    (@mmwbadmin)

    Hi, that would be great. But first enjoy your weekend!
    My site can do without both Redis and OPcache πŸ˜‰
    Of course your effort is greatly appreciated; nice to see it solved.
    Don’t hesitate to write in case of any question. Thanks in advance.

    Plugin Author Pierre Lannoy

    (@pierrelannoy)

    Hi!
    I was able to reproduce this issue with Redis (with Redis Object Cache plugin, LiteSpeed Cache but not with W3TC) only when Redis cache is activated AND where Redis servers are not working properly (unatainable servers for instance)…
    Can you confirm your Redis server(s) are working without issues?

    Thread Starter mmwbadmin

    (@mmwbadmin)

    Hi,
    Can’t confirm it’s working properly. Webhost told me I just needed a host IP and port number. With previous web host (2 weeks ago) I needed a password and database ID as well. So I have host-IP 127.0.0.1 port **** and DB ID = 0.
    Hope this helps.

    Plugin Author Pierre Lannoy

    (@pierrelannoy)

    What happens if you disable Redis for, say, half an hour?
    Are the statistics visible? Does your site show unexpected behavior?

    Thanks.

    Thread Starter mmwbadmin

    (@mmwbadmin)

    Hi,
    have Redis extension disabled. No notable difference or unexpected behavior (for now). Same speed & scores in GTmetrix. We’ll leave it there for a while πŸ˜‰

    Thread Starter mmwbadmin

    (@mmwbadmin)

    Hi,
    in Query Monitor – on page /admin.php?page=opcm-viewer – I got a message that PHP errors occurred during an AJAX request.
    In dev console it reads:

    [Warning] Object (query-monitor.js, line 371)

    component: “Plugin installeren: opcache-manager”

    file: “wp-content/plugins/opcache-manager/includes/features/class-schema.php”

    key: “0b********************19c6”

    line: 269

    message: “implode(): Passing glue string after array is deprecated. Swap the parameters”

    stack: [“implode()”, “OPcacheManager\\P\\F\\Schema::get_std_kpi()”, “OPcacheManager\\P\\F\\Analytics->query_kpi()”, “OPcacheManager\\P\\F\\Analytics->query()”, “OPcacheManager\\P\\F\\AnalyticsFactory::get_stats_callback()”, “do_action(‘wp_ajax_opcm_get_stats’)”] (6)

    type: “deprecated”
    …………(goes on)

    Of any help?

    • This reply was modified 8 months ago by mmwbadmin.
    Plugin Author Pierre Lannoy

    (@pierrelannoy)

    Hi!
    Thanks for the hint. This warning is due to a compatibility issue with PHP 7.4… It will be fixed in the next release (I will push it in the next hours if all go well).
    Regarding the initial issue (blank analytics), I found something which is really “strange”: with some specific configurations (for plugin embedding Redis capabilities), transient/memory object are not stored the same way. It can explain the issue you’re experiencing and the next release will implement a fix for that too.

    Let me some hours to clean my code and push the new release on WP directory…

    I’ll let you know as soon as the new release is ready.

    Thread Starter mmwbadmin

    (@mmwbadmin)

    Hi,
    turned out Redis object cache is not working on my site as it isn’t offered on shared hosting at my web host (though I can activate the PHP extension).
    LSC plugin has an option for storing transients in the db when object cache is turned off for the backend.
    Hope this helped to improve your plugin πŸ˜‰
    Thanks in advance

    Plugin Author Pierre Lannoy

    (@pierrelannoy)

    New version is released πŸ™‚
    When you’ve updated, will you let me know how it turns out?

    Thanks.

    Note: it may take 10-15 minutes before first analytics appear.

    Thread Starter mmwbadmin

    (@mmwbadmin)

    Hi,
    sorry to say, but no difference.
    Records in table opcm_statistics now have status ‘enabled’ instead of ‘recycle_in_progress’ but other fields have value=0.
    Same behavior with PHP 7.2
    Site diagnose (under PHP 7.4) suggests to use object cache (R or M), but OPcache is running smoothly with >950 cached scripts – same as your plugin mentions – and hit rate = 90%

Viewing 15 replies - 1 through 15 (of 29 total)
  • The topic ‘Analytics empty’ is closed to new replies.