Support » Plugin: OPcache Manager » Analytics empty

  • Hi,
    OPCache Analytics (Zend OPcache 7.4.7) is empty, while OPcache Management displays > 850 files (with some hits).
    I would expect them to show up in PerfOps Analytics OPcache, but Hit Ratio through Buffer Saturation = 0, Availability = 100%.
    Am I missing something?

    The page I need help with: [log in to see the link]

Viewing 14 replies - 16 through 29 (of 29 total)
  • Plugin Author Pierre Lannoy

    (@pierrelannoy)

    Wow! Incredible. and a bit disappointing 🙁

    Is the option to store transient in DB is activated?

    Hi,
    transients are stored in the DB (otherwise my own plugin doesn’t function 😉 ).

    I am also experiencing the analytics being empty.

    WP: 5.4.2
    PHP: 7.2.31
    OPCache Manager: 1.3.2

    Zend OPCache enabled and showing 2,000+ files in the Manager with hits but no analytics. I assume the OPCache is working as there are cached files with hits, but the analytics would be cool.

    • This reply was modified 1 month, 1 week ago by aptx.
    Plugin Author Pierre Lannoy

    (@pierrelannoy)

    Oh my! But it’s an epidemic! 🙁

    Ok, so now, we have two cases.
    We will compare.

    Can you first (for you both) confirm you have an operational cron and which method of cron you use.
    If you use the standard WP cron method, can you tell me what’s the “average” traffic on your site (because standard WP cron relies on traffic)?
    If you use alternative method, can you tell what’s the set frequency?

    Thanks

    Server cron operational at 5 min interval (*/5).
    Creates records in table opcm_statistic (enabled/none/0/0/0…/0)

    Hi,
    this appears in debug log
    PHP Warning: array_key_exists() expects parameter 2 to be array, bool given in wp-content/plugins/opcache-manager/includes/features/class-capture.php on line 87
    (& lines 90, 93, 109, 115, 121, 127, 130, 133, 139,142, 145, 148, 159, 162, 166 + 169)

    I am using the standard wp cron. Did not check the interval, but checking today the stats are showing. This may have been a traffic/timing thing.

    Plugin Author Pierre Lannoy

    (@pierrelannoy)

    Thanks for your feedback @aptx… That’s good news 🙂

    Plugin Author Pierre Lannoy

    (@pierrelannoy)

    Thank you so much @mmwbadmin ! Thanks to this invaluable information, I know what’s going on (note, I don’t know the “why”).
    That’s simple: the standard php function (the one which is responsible to get OPcache) failed to execute… There may be several reasons but the most likely is that OPcache is in “file cache only” mode.
    Could you please verify something? In your admin dashboard, go to the “Tools” menu, click on “Site Health”, then click on the info tab (at the top of the screen). You will obtain a list of cheks, go to OPcache section and tell me if you have “[Directive] file_cache_only => {nothing}” or “[Directive] file_cache_only => 1”. If you have the second one, the problem is here…

    Hi,

    it shows [Directive] file_cache_only => {nothing}

    Plugin Author Pierre Lannoy

    (@pierrelannoy)

    Hi!
    That’s definitely strange. We will try something else: can you send me Site Info?

    Here is how to obtain Site Info: go to the “Tools” menu, click on “Site Health”, then click on the info tab (at the top of the screen) and use the button “copy site info to clipboard”…
    After that, just create a blank txt file and paste the site info in it. Then, send me the file by mail at the following address: [my_first_name] @ [my_last_name] .fr

    Thanks in advance.

    (Note that sensitive or personal information are removed by WordPress from these infos)

    Plugin Author Pierre Lannoy

    (@pierrelannoy)

    Thank you so much to send me your info file @mmwbadmin!

    That’s really strange, you have the same settings as me… There is no reason why the behavior should be different… unless PHP introduced a regression bug in 7.4.7 (I can only test with 7.4.1).

    There’s a way to test this assumption. If you’re comfortable with file modification, you can change a paremeter in the following file:
    wp-content/plugins/opcache-manager/includes/features/class-capture.php
    in lines 83 and 183, just replace opcache_get_status( false ); by opcache_get_status( true ); and after 10-15 minutes you may see right stats.

    If it’s the case, I will make a patch to support this…

    That’s odd indeed. Changes on lines 83 & 183 had no effect.
    This issue might be connected – on my side – to another one that I encounter since moving to a new host on June 20.
    I can not save changes to .php files in the active theme from within WP (plugin & theme editor), while this works for e.g. .css files and for all files in non-active themes. Made the above changes via cPanel File Manager.
    I’m not using multi-ste.
    Perhaps I should contact my host for this.

    mmwbadmin

    (@mmwbadmin)

    Can save changes via plugin & theme editor again. For OPcache Manager I call it a day for now. A pity we couldn’t solve the issue. Thanks for your assistance.

Viewing 14 replies - 16 through 29 (of 29 total)
  • You must be logged in to reply to this topic.