Support » Plugin: Listings Jobs » Activating give http error 500

  • Resolved Peder

    (@tunadmin)


    Hi!

    When I try to install this on a test server, I get at Http error 500.
    As soon as I delete the folder from the plugins folder, my site come back up again.

    I’m using WordPress 4.5.3 with a custom theme.
    Listing version 0.3.0 is installed an activated.

    Cheers,
    Peder

    https://wordpress.org/plugins/listings-jobs/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Coen Jacobs

    (@coenjacobs)

    Can you please enable debug mode on your site and activate the Listings Jobs plugin again? This might show us the actual error that is being suppressed under that 500 HTTP error.

    Can you also please verify that you’re running the latest stable version of Listings Jobs (currently v0.2.1)?

    Hi!

    Here is the “instal result”:

    Laster ned installasjonspakke fra (https://downloads.wordpress.org/plugin/listings-jobs.0.2.1.zip)…

    Pakker ut pakken…

    Installerer utvidelsen…

    Installerte utvidelsen Listings Jobs 0.2.1.

    So far so good.
    And the I activate the plugin.
    Then I just get this:
    Parse error: syntax error, unexpected T_CLASS, expecting T_STRING or T_VARIABLE or '$' in /DATA/apache/html/stage/wp-content/plugins/listings-jobs/src/Plugin.php on line 64

    Cheers 🙂

    Plugin Author Scott Basgaard

    (@scottbasgaard)

    Thanks for reporting this issue.

    It looks like we’ve got some code that needs to be refactored for PHP 5.3 compatibility.

    As we want to keep a minimum requirement of 5.3 we’ll working on a quick fix right now and will update you once we’ve got something committed to .org for you to download and get on your way.

    Again, appreciate you reporting this issue and your patience here.

    Kind Regards,
    Scott

    Hi!

    No worries. I was starting to look at PHP as the culprit myself.

    If you need to know the server I’m working on is using PHP 5.3.3.

    Kind regards,
    Peder

    Plugin Author Coen Jacobs

    (@coenjacobs)

    Thanks again for reporting this. I’ve just released version 0.2.2 and that version fixes this issue. Please let us know if this resolved all the issues that you have. 🙂

    Coen – Although not a developer I do extensively use the Job Manager plugin in two sites focused on third party recruitment.

    Are you open to feedback and suggestions from a user actually using the plugin? If so I’d love to give a few real world examples of using it and problems in using it that could be easily corrected to add value.

    Plugin Author Coen Jacobs

    (@coenjacobs)

    Yes, absolutely Bill. All feedback is absolutely valuable, not just developers feedback. We’re confident that the majority of users of our platform aren’t developers, so non-developer problems are probably the most important for us. 🙂

    Please create a new forum thread for each problem you find. It’s easier for us to deal with multiple issues in separate threads. Thank you!

    Hi!

    Version 0.2.2 solved my 500-problem.
    Thank you 🙂

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Activating give http error 500’ is closed to new replies.