WordPress.org

Plugin Directory

Test out the new Plugin Directory and let us know what you think.

WP GPX Maps

Draws a gpx track with altitude graph. You can also display your nextgen gallery images in the map.

This plugin has, as input, the GPX file with the track you've made and as output it shows the map of the track and an interactive altitude graph (where available).

Now on github: https://github.com/devfarm-it/wp-gpx-maps On github you can contribuite easly with your code

Fully configurable: - Custom colors - Custom icons - Multiple language support

Supported charts: - Altitude - Speed - Heart Rate - Temperature - Cadence - Grade

NextGen Gallery Integration:

Display your NextGen Gallery images inside the map! Even if you don't have a gps camera, this plugin can retrive the image position starting from the image date and you gpx file.

Old NGGallery Images (without gps data) and gpx: http://www.pedemontanadelgrappa.it/mappe/itinerario-3-alta-via-degli-eroi/

Post Attachments Integration:

This version is extended by Stephan Klein (https://klein-gedruckt.de/2015/03/wordpress-plugin-wp-gpx-maps/) and supports displaying all images attached to a post without using NGG.

Translated into 14 languages:

  • Catalan ca
  • Dutch nl_NL
  • English (default)
  • French fr_FR
  • German de_DE
  • Hungarian hu_HU
  • Italian it_IT
  • Polish pl_PL
  • Portuguese (Brazilian) pt_BR
  • Russian ru_RU
  • Spanish es_ES
  • Swedish sv_SE
  • Turkish tr_TR
  • Bulgarian bg_BG

(many thanks to all guys who helped me with the translations)

  • iphone/ipad/ipod Compatible

Try this plugin: http://www.pedemontanadelgrappa.it/category/mappe/

Support Forum

Supported gpx namespaces are:

  1. http://www.topografix.com/GPX/1/0

  2. http://www.topografix.com/GPX/1/1

  3. http://www.garmin.com/xmlschemas/GpxExtensions/v3

  4. http://www.garmin.com/xmlschemas/TrackPointExtension/v1

Thanks to: http://www.securcube.net, http://www.devfarm.it, http://www.pedemontanadelgrappa.it

Up to version 1.1.15 Highcharts-API is the only available rendering engine. Please respect their license and pricing (only Free for Non-Commercial usage).

Requires: 2.0.0 or higher
Compatible up to: 4.6.1
Last Updated: 1 month ago
Active Installs: 4,000+

Ratings

4.6 out of 5 stars

Support

0 of 4 support threads in the last two months have been marked resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1 100,1,1
100,1,1 100,1,1 100,1,1 100,2,2
100,1,1 100,1,1 100,1,1 100,2,2 100,1,1 100,1,1 100,1,1 100,1,1 100,1,1 100,2,2
100,1,1 100,1,1 100,1,1
100,1,1 100,1,1
100,1,1 100,1,1 100,1,1 100,3,3 33,3,1
0,1,0 100,1,1 100,2,2
100,1,1 100,1,1
100,1,1
100,2,2
50,2,1
100,1,1
33,3,1
100,1,1
50,2,1
0,1,0
0,1,0
100,2,2
33,3,1
100,1,1
100,1,1
100,1,1
33,3,1