WordPress.org

Plugin Directory

Test out the new Plugin Directory and let us know what you think.

CopySafe PDF Protection

Display copy protected PDF documents in WordPress pages and posts.

This plugin enables the use of copy protected PDF documents in WordPress posts and pages with shortcode. The resulting embedded PDF object is supported in the ArtistScope web browser. Earlier versions of popular do support real plugins, but as of late 2015 all poplar web browsers dropped support for real plugins to focus on support for phoines and other amusement devices. However the option to allow select browsers remains so that intranets using older browsers can be allowed access.

CopySafe PDF provides the most secure protection for PDF both online and offline. This plugin displays PDF created for use online and when domain lock is applied, the PDF file cannot be displayed from anywhere else. With PDF now bound to your web site, you are free to apply DRM rules to control access to the page via your CMS member controls. The ArtistSWcope web browser reports the user's unique computer signature so that you can convert WordPress into a fully fledged DRM Portal by adding a new field to your member's table and some script to compare current ID with the one already assigned.

  • Easy install.
  • Insert protected PDF into posts and pages using the [PDF] media button.
  • Upload and embed secure PDF using WordPress native media tools.
  • Embeds objects dynamically using JavaScript.
  • Set varying levels of protection per page or post.
  • Detects PDF plugin version for redirection and installation.
  • Settings to control width and height of the browser reader area.
  • Safe from Print Screen and all screen capture software.
  • PDF documents cannot be saved and displayed any from your website.

For more information visit the CopySafe PDF website.

Requires: 4.0 or higher
Compatible up to: 4.7.2
Last Updated: 1 month ago
Active Installs: 500+

Ratings

3.6 out of 5 stars

Support

1 of 1 support threads in the last two months have been marked resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

0,2,0
100,1,1