kawo83
Forum Replies Created
-
Forum: Plugins
In reply to: [Kustom Checkout for WooCommerce] Javascript Error on CheckoutI did post this in the wrong plugin support, you can delete this topic.
Forum: Plugins
In reply to: [PayPal Plus for WooCommerce] paymentId cannot be nullSame problem for me. No Woocommerce Germanized installed.
2021-05-29T16:56:50+00:00 ERROR paymentId cannot be null 2021-05-29T16:56:50+00:00 ERROR paymentId cannot be null 2021-05-29T16:56:50+00:00 ERROR paymentId cannot be null 2021-05-29T16:56:50+00:00 ERROR paymentId cannot be null 2021-05-29T16:56:50+00:00 ERROR paymentId cannot be null 2021-05-29T16:56:50+00:00 ERROR paymentId cannot be null 2021-05-29T16:56:50+00:00 ERROR paymentId cannot be null 2021-05-29T16:56:50+00:00 ERROR paymentId cannot be null 2021-05-29T16:56:50+00:00 ERROR paymentId cannot be null 2021-05-29T16:56:50+00:00 ERROR paymentId cannot be null 2021-05-29T17:07:53+00:00 INFO POST https://api.paypal.com/v1/payments/payment 2021-05-29T17:07:53+00:00 INFO Response Status : 201 2021-05-29T18:01:41+00:00 INFO POST https://api.paypal.com/v1/payments/payment 2021-05-29T18:01:42+00:00 INFO Response Status : 2012021-05-27T09:17:34+00:00 CRITICAL Uncaught Error: Call to a member function getPayerInfo() on null in /var/www/vhosts/abcdefg.de/httpdocs/wp-content/plugins/woo-paypalplus/src/ExpressCheckoutGateway/CheckoutAddressOverride.php:152Is it possible deactivate the whole express checkout part of the plugin? If possible by code, please let me know which code i need to comment out.
I am using angelleye paypal extress checkout for this.
Thanks, please help fast its making a lot of trouble to merchants.
Forum: Plugins
In reply to: [Klarna for WooCommerce] Websocket errorOk, on my development system I got it to work.
The problem is caused by following plugin: PayPal Plus (the one by angelleye)
once deactivated, it works. How to fix this now? PayPal Plus is mandatory for me so I can’t just go without it.
Forum: Plugins
In reply to: [Klarna for WooCommerce] Websocket errorHello,
it is not related to cloudflare, any cloudflare security is disabled on cart / checkout to prevent problems. also on top of the websocket errors, I get this message:
Fehler beim Bezahlvorgang. Versuche es bitte nochmal.
there is no additional error on this in console, in ajax response, in php or apache logs.
It is not template related (same in default template of wordpress)
Forum: Plugins
In reply to: [Klarna for WooCommerce] Websocket errorHow to Fix the NET::ERR_CERT_AUTHORITY_INVALID Error
I don’t have this error I think. My Cert is signed for the domain, no self signed.
Same problem to me. He has no API error, this is plugin related.
look my topic at: https://wordpress.org/support/topic/websocket-error-2/
This is a image where you can see what i need to do. My Problem is that the count of <prop> elements is different in each node, so i need to get the value of <prop> element with <propid>41</propid>.
Hello,
thanks I will do. But funny I probably found the solution (I will do some more testing or reach you out).
It seems all problems caused by the REDIS object cache. I disabled it and for now all is working.
I am about to give up, there must be something seriously broken in the database about the plugin and I need to delete all related stuff from database. Sadly with deactivate and remove the database related stuff does not get deleted.
I can’t even change any options now (changing setting is not saved), XML files are processing fine until 100% all good, the problem is there is no xml generated lol.
I have no fatal errors, no cache enabled and read all advises multiple times. Seems my 100 bucks are wasted since it really start tilting my experience after 15 hours+ debugging with nothing helps at all.
Hello there, I found a solution to the problem, but I think its a problem need to be fixed by developers.
The following command changed from 5000ms to 20000ms
myInterval = setInterval(woosea_check_perc,5000);The problem with this interval is, on like 8 product feeds, it spawns 8 ajax post requests each 5 seconds and after some time the server is behind the responses due to flood of requests.
My question is, why is a request done also for the feeds not clicked manual refresh and not only the one feed clicked? This would solve the problem and I could change it back to 5000.
Hello,
yes I have all plugins updated to newest version, also I am using the elite version of plugin.
// Replace status of project to processing $("table tbody").find('input[name="manage_record"]').each(function(){ var hash = this.value; if(hash == project_hash){ $(".woo-product-feed-pro-blink_off_"+hash).text(function () { $(this).addClass('woo-product-feed-pro-blink_me'); var status = $(".woo-product-feed-pro-blink_off_"+hash).text(); console.log("Set interval on manual refresh"); myInterval = setInterval(woosea_check_perc,5000); if(status == "ready"){ return $(this).text().replace("ready", "processing (0%)"); } else if (status == "stopped"){ return $(this).text().replace("stopped", "processing (0%)"); } else if (status == "not run yet"){ return $(this).text().replace("not run yet", "processing (0%)"); } else { // it should not be coming here at all return $(this).text().replace("ready", "processing (0%)"); } }); } });this is the javascript part doing the request all 5 seconds and spawning hundreds of php-fpm worker. What me wonder is that delete plugin and reinstall still there are settings in database left. Is it possible doing a 100% clear of the plugin and start from scratch? I would do that to not waste your time myself.
Also I can offer you a login for further debugging
edit: I also found that my main feed is ignoring filters, I deleted them and did new. Still ignoring things.
Product Feed Elite Version: 1.7.8
Product Feed Pro: Not installed.Some more info: I think the main problem is that on the manage feed site as soon as I press manual refresh, Ajax requests are keep spawning in developer console of browser. When I immediately leave manage feeds after pressing refresh and watch cron, the cron batch updates seems working normal. So the Ajax calls whatever they do are killing my server and I think that’s also the reason normal batch updates aren’t completing then.
Server load increasing to 100-200 in 1 5 and 15min display
Hello, yes I found the exclude extra field already. I was hoping there is a more bulk Support way since I could download the csv from google shopping and use the list of ids in some way.