HTTPS Free SSL Dot Tech
Forum Replies Created
-
@officecyber Thank you very much for the support!
@tdsbc Sorry to see you go.
I have already told that this issue is not within our plugin.
cURL is a minimum system requirement for this plugin. The problem is with cURL. Fixing that issue needs some experience in Linux server administration. If you can’t fix the issue, please take the help of a professional Linux server administrator.
Renewing an SSL certificate is nothing but creating a new one. Once the cURL issue is resolved, the plugin will function properly.
Something has been changed in the server after you generated the SSL certificate the first time.
As per the information provided by you over email, this file does not exist in the server: /etc/ssl/certs/ca-certificates.crt
Please click here to read how their Support Engineers fixed the cURL error 77 issues for their customers.
According to that blog post, running the following command may fix the issue if you are on a CentOS server.
yum reinstall -y ca-certificatesIf your server is not CentOS, please look at the command from the server’s documentation that does the same job.
If you can’t fix the issue with the above blog post’s information, please search Google with “curl error 77 how to fix” or any relevant keywords.
This update is for other users who may have been facing the same issue.
@tdsbc provided us with the complete log, which includes the following line:
cURL error 77: error setting certificate file: /etc/ssl/certs/ca-certificates.crtUnfortunately, the above cURL error is something that must be resolved by your web hosting provider.
The document root of the WordPress website is
/var/www/htmlSo, the reported path (/etc/ssl/certs/ca-certificates.crt) is out of control by WordPress, and hence any plugin.Due to this cURL error, our plugin can’t connect with the Let’s Encrypt API server. (Let’s Encrypt issues the SSL certificate.)
Please send a link to this forum post to your web hosting provider and request help.
Please check this link for a similar issue: https://wordpress.org/support/topic/curl-error-77-error-setting-certificate-verify-locations/ This is a different plugin, and it is developed by Google. But the issue is the same.
@daresuk That is covered by both PRO and PRO unlimited version. Please note that, all the domains should point to the same document root in the cPanel.
Please send an email to support AT freessl.tech (remove AT with @ and the space before and after it) if you need more information.
Thank you.
@daresuk, The free version of the plugin covers the common practice example.com and http://www.example.com because most users use this variation.
So, unfortunately, adding 2nd domain to the SSL certificate is not possible with the free version. We are sorry.
However, if you have cPanel and the second domain is added in the cPanel, and it points to the same document root, the plugin’s premium version will cover it.
@tdsbc We need details information to help you.
Please share the full-page unedited screenshot when you get the error.
Please send me the complete Log in text format.
From the plugin’s menu at the left-hand sidebar, you’ll find the Log menu.
If you hesitate to post the information publicly here, please send all the information to support AT freessl.tech (remove AT with @ and the space before and after it).
@habitudeenglishapi Making a XAMPP localhost server online is like creating your in-house web hosting server that is accessible online, which is out of the scope of this WordPress plugin.
Please search Google with keywords like “make xampp server online”, “how to make xampp server public” etc, and proceed yourself.
Please Note: Making your XAMPP server accessible online carries security risks. Ensure that you have implemented appropriate security measures, such as strong passwords, secure configurations, and regular updates, to protect your server from unauthorized access.
@cdamtoft You are using the premium version of this plugin. However, we are not allowed to provide premium support here.
Please send an email to support @ speedify.tech (remove space before and after @) from the email id with which you purchased the plugin. We’ll fix the issue.
Please attach a full-page screenshot of the Log and also the complete Log in a text file.
You’ll find the Log menu from the plugin’s menu at the left-hand sidebar.
For any questions, please send an email to support @ speedify.tech
@habitudeenglishapi One of the MINIMUM SYSTEM REQUIREMENTS of this plugin is: the website should be assigned to a domain name (e.g., example.com) accessible online. Because Let’s Encrypt will verify the domain ownership online. After successful verification, they will issue a free SSL certificate to the domain.
If your local XAMPP localhost environment is not accessible online, please make it accessible online. Then assign a domain name to it.
Then you can go ahead and install our plugin and do the required steps to verify your domain ownership and generate an SSL certificate.
Please let me know if you have any questions.
@mtgpuzzles Thank you for your feedback.
It’s optional paying us to get Free SSL Certificates using our plugin.
This free plugin provides free SSL Certificates (minus automation). The free version has no automation for domain verification and SSL installation. Free users can follow the installation tab for the written and video documentation and manually do these tasks to get free SSL certificates from their WordPress dashboard. The premium version does everything with complete automation. This fact is mentioned in the plugin description. We have written FREE PLUGIN FEATURES and PREMIUM PLUGIN FEATURES transparently.
We announced the pro version on November 3, 2020. We explained the difficulties of spending hundreds of hours developing the plugin and then spending time providing support without any monetary return. Since then, for 1 year and 8 months, we notified our users with admin notice with a link to this blog post: https://freessl.tech/blog/auto-install-free-ssl-needs-your-help-to-survive/
According to the announcement, we offered our previous users (users before releasing the premium version on June 29, 2022) 6 months of the premium license for unlimited websites, free of cost (June 29, 2022, to December 31, 2022 ). We then provided a 30% discount till January 31, 2023, to purchase the premium version.
The benefits of the Free version are that users still get
Let’s Encrypt™ SSL Certificate is FREE. But they provide it through their API. If you are not a programmer, you need to study and practice programming for years to be able to use the API of Let’s Encrypt™ to generate the first Free SSL Certificate for your WordPress website.
Here is where this plugin comes into play. This WordPress plugin provides a hassle-free way to obtain the Let’s Encrypt™ free SSL certificate for your website. You don’t need programming or coding experience.
However, the users need to spend some time using this plugin to generate & install the SSL certificate and repeat this for every renewal (every 2-3 months). The premium version does this for the users automatically and saves users’ time. Time is money for many people. Now it’s the users’ choice which version they use.
Regarding the plugin’s pricing, many popular web hosting companies charge $100 or more for one year SSL certificate. We know users used to purchase products they found cheaper.@jgarnick Thank you so much for your support.
@ivanturatti Thank you very much for your support.
@ibisrod Thank you very much for your support.
@silver0202 Thank you very much for your support.