Forum Replies Created

Viewing 10 replies - 16 through 25 (of 25 total)
  • Daniil S.

    (@dscelectronicsde)

    Hi,

    as far as i understand the originally released version 5.126 was faulty (crashed 5 of our WP shops), and you rolled it back to 5.125. Then you released a fix, with the same version number 5.126 – from my point of view this is a critical failure because those who updated to the faulty version 5.126 do not receive the new fix, until they manually remove the plugin and re-install. The correct way of issuing the fix would be to update it to a higher version, for example 5.127 so it gets updated automatically on the affected wp sites.

    Best

    Dan.

    • This reply was modified 7 years ago by Daniil S..
    Thread Starter Daniil S.

    (@dscelectronicsde)

    Hi @vxfusion,

    thank you very much for saving a lot of my time trying to find out where to fix the code, i knew it has to do with the way windows (IIS) and the plugin handle the paths – but i had no time so far to inspect the code to find out how to fix it. I tried your fix but unfortunately there seems to be a problem somewhere, with the latest version of W3C it gives me a 500 error as soon as i access the W3C config pages.

    Best

    Dan

    • This reply was modified 7 years ago by Daniil S..
    Thread Starter Daniil S.

    (@dscelectronicsde)

    Dear Marko,

    we now have placed the website to a live system and we can give you access to the backend to test it out. In order to send you the credentials could you please contact me via mail at: d.safarenko(at)dsc-electronics(dot)de

    Thread Starter Daniil S.

    (@dscelectronicsde)

    Hi, any news on this issue ?

    Thread Starter Daniil S.

    (@dscelectronicsde)

    Hello Marko,

    unfortunately i can not share a url, as the website is running on a local test environment and is not accessible via the net. No, we are not using any other caching plugins, we normally use a CDN network but this is disabled in the test environment.

    Thread Starter Daniil S.

    (@dscelectronicsde)

    Hello Marco,

    thank you for your quick reply.
    Yes, the problem persists after clearing the cache and deleting the minify cache folder.

    Thread Starter Daniil S.

    (@dscelectronicsde)

    Hi Eva,

    thank you for your reply.
    Could you please contact me via mail at “service (at) dsc-electronics (dot) de” ? I would like to send you the plugin files of the shipment plugin i use, also as i really need these two plugins to be compatible i would support you with a payment to make these plugins compatible if possible.

    Waiting forward for your mail!

    Best

    Dan

    Thread Starter Daniil S.

    (@dscelectronicsde)

    Guten Tag !

    Heute hat sich das Problem von alleine gelöst, das Plugin funktionierte auf einmal korrekt ohne dass wir etwas an der Konfiguration oder am Server geändert hätten. Vermutlich ist das Konto bei PayPal verzögert freigeschaltet worden. Wie auch immer, vielen Dank für den Support und einen angenehmen Tag !

    MfG

    Daniil Safarenko

    Thread Starter Daniil S.

    (@dscelectronicsde)

    Guten Tag !

    Error Log:

    [Mon Dec 04 09:46:35.658218 2017] [proxy_fcgi:error] [pid 1474:tid 140106455279360] [client 2a02:908:696:8c80:d9e0:a410:6097:664c:52475] AH01071: Got error ‘PHP message: PHP Fatal error: Uncaught Inpsyde\\Lib\\PayPal\\Exception\\PayPalConfigurationException: Getter function for ‘payments’ in ‘Inpsyde\\Lib\\PayPal\\Api\\PaymentHistory’ class should have a proper return type. in /var/www/vhosts/dsc-electronics.com/httpdocs/dsc-electronics.de/wp-content/plugins/woo-paypalplus/lib/PayPal/Common/ReflectionUtil.php:60\nStack trace:\n#0 /var/www/vhosts/dsc-electronics.com/httpdocs/dsc-electronics.de/wp-content/plugins/woo-paypalplus/lib/PayPal/Common/PayPalModel.php(210): Inpsyde\\Lib\\PayPal\\Common\\ReflectionUtil::getPropertyClass(‘Inpsyde\\\\Lib\\\\Pay…’, ‘payments’)\n#1 /var/www/vhosts/dsc-electronics.com/httpdocs/dsc-electronics.de/wp-content/plugins/woo-paypalplus/lib/PayPal/Common/PayPalModel.php(271): Inpsyde\\Lib\\PayPal\\Common\\PayPalModel->fromArray(Array)\n#2 /var/www/vhosts/dsc-electronics.com/httpdocs/dsc-electronics.de/wp-content/plugins/woo-paypalplus/lib/PayPal/Api/Payment.php(675): Inpsyde\\Lib\\PayPal\\Common\\PayPalModel->fromJson(‘{“payments”:[],…’)\n#3 /var/www/vhos…\n’, referer: https://dsc-electronics.de/wp-admin/admin.php?page=wc-settings&tab=checkout&section=paypal_plus

    Bei weiteren Fragen helfe ich Ihnen gerne.

    Mit freundlichen Grüßen

    Daniil Safarenko

    Thread Starter Daniil S.

    (@dscelectronicsde)

    Sehr geehrter Andreas,

    tut mir leid für die Verzögerung, ich hatte auf Ihre E-Mail geantwortet ohne zu bemerken dass diese als “noreply” gekennzeichnet ist.
    Ich habe alle Plugins deaktiviert und es wiederholt versucht, der Fehler bleibt bestehen.
    Die Experience Profil ID wird automatisch beim Speichern der Einstellungen generiert,
    das passiert bei mir jedoch nicht da es zum 500 HTML Error kommt.
    Ja, mein PPP Account ist freigeschaltet.

    > Siehe ganz oben PayPal Plus aktivieren. Dann speichern und schauen, ob eine ID generiert wurde.
    Habe ich versucht, selber Fehler. Die ID wird nicht generiert.

    Mit freundlichen Grüßen

    Daniil Safarenko

Viewing 10 replies - 16 through 25 (of 25 total)