Support » Plugin: Custom VC Column Layout » You don't need this plugin.

  • User jamiesmachon left a comment with a work-around to get this plugin to work, but for those still having the issue of 5 column layouts – don’t both downloading this.
    I’ll be honest, I didn’t even download it to try it, I read the reviews and a few people said it doesn’t work, also jamiesmachon left the work-around I mentioned.
    This ‘work-around’ actually works on it’s own without the plugin. I’ll paste his comment back here again. No need to download, just copy & paste. You can use the custom CSS space on the page you are working on (the gear icon, top right of VC editor) to include the code (no need to edit back-end CSS), and just add the custom classes to the elements as he specified.
    Thanks Jamie!

    Hi everyone, I dont know if it was due to the latest updates to WordPress and VC but I had to modify the code I use to get this plugin to work again.

    As before I installed the plugin as normal.

    I then assigned a custom class to the row itself (one-fifth-row) and then a class to each of the first 4 element (one-fifth) then the final element was given another class (one-fifth-last).
    Please note that as before the column layout goes a bit mad and changed to 1/12 from 1/5 as soon as I saved the custom classes. To remedy this again simply re-selected the 1/5 layout and updated the page.

    I then applied the below css code to the style.css file.

    .one-fifth-row .vc_col-sm-3 {
    	width: 19%;
    }
    .one-fifth {
    	float: left;
    	width: 18.8%;
    	padding: 0;
    	margin-right: 1.2%;
    	min-height: 0;
    }
    .one-fifth-last {
    	float: left;
    	width: 20%;
    	padding: 0;
    	margin-right: 0;
    	min-height: 0;
    }
    
    @media (max-width: 768px) {
    	.one-fifth-row .vc_col-sm-3 {
    		width: 100%;
    	}
    	.one-fifth,
    	.one-fifth-last {
    		float: none;
    		width: 100%;
    	}
    }

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘You don't need this plugin.’ is closed to new replies.