Support » Plugin: Yoast SEO » Sitemap Warning Message

  • Resolved fabiocibello

    (@fabiocibello)



    Hello Yoast SEO staff,

    I need your help because this is my 3rd day full immersion on this issue and I can’t find a solution.

    In the YOAST GENERAL SETTINGS of my website, there is always a warning message:

    The following / file (s) prevents / s to your XML sitemap to function properly
    /home/fabiocibello/public_html/sitemap.xml
    You can delete them (you can do this by pressing the button “Solve the problem”), or you can disable Yoast SEO XML sitemaps.

    I don’t know what it is and how/where I can fix this problem.
    – I changed my sitemap link adding the address created by Yoast /sitemap_index.xml.
    – I told to Google Search Console my new sitemap address.
    – I have very few plugin installed on my website, but I tried to turn them off to see if there was any incompatibility issues with Yoast SEO plugin but nothing.
    – I changed the robots.txt file with:
    User-agent: *
    Disallow: /wp-admin/
    Sitemap: http://www.fabiocibello.com/sitemap_index.xml

    Hope someone can help me as soon as possible.

    THANKS,
    Fabio

    https://wordpress.org/plugins/wordpress-seo/

Viewing 8 replies - 1 through 8 (of 8 total)
  • I had the same problem recently, i haven’t made any changes to Yoast seo plugin and got the same message.

    This is because we had another sitemap named “sitemap.xml” that was conflicting with Yoast seo plugin, i have no idea where it came from.

    After this message i have deleted sitemap.xml in public_html directory, resaved “changes” under SEO/general tab/save changes and everything was ok again, check here http://www.optimizacijasajta.org/sitemap_index.xml.

    Anyway sitemap.xml is redirected to sitemap_index.xml by the plugin maybe that is the problem with your sitemap.xml file.

    You can try to backup your sitemap.xml just in case on your device and then to delete it from your server.

    Hope this helps,

    best regards,

    Branislav

    Hello Branislav,

    I already deleted my sitemap.xml file but nothing happen and my warning message is still there.

    My sitemap.xml is NOT redirected to sitemap_index.xml. How did you do that?
    How can I redirect my sitemap.xml to sitemap_index.xml?

    Thanks,
    Fabio

    Hi.

    I having the same problem with the second and third language. The first language its loading well in Google Search Console but with the rest of language that’s impossible… always problems with Yoast.

    My solution?. Disable yoast sitemap and use Google Sitemaps XML to solve this problems.

    Good luck.

    @banjavrujci
    Hi…my sitemap_index.xml … see here.
    But see here https://pppdog.me/post-sitemap.xml

    Hope someone can help me as soon as possible.

    THANKS.

    @fabio @zeng pppdog

    Hm, sitemap.xml should be redirected by default to sitemap_index.xml by Yoast seo plugin i don’t know why it is not, check here

    What permalinkns structure are you using, can you flush your permalinks and try again in settings/permalinks put to default and save and then revert like it is now…

    Are you using any caching plugin? If yes you should clear cache after flushing permalinks…

    What plugins are you using, maybe some plugin is conflicting with Yoast seo?

    Are you sure you don’t have another sitemap file in public_html directory, have you enabled show hidden files and check again?

    You can try to disable sitemap functionality in admin under SEO/XML Sitemaps set to disabled and save. Clear the cache if you are using any caching plugin. Go again to SEO/XML Sitemaps, enable XML sitemap functionality, choose desired options and save. Clear the cache if you are using some caching plugin and see if everything is ok now.

    Also you can try to disable other plugins, resave changes under SEO/XML Sitemaps clear the cache and see if this helps.

    Do you have any error_log that can give us some more info?

    Branislav

    Hello Branislav,

    I answer to your question:
    1. What permalinkns structure are you using, can you flush your permalinks.
    – I did that but nothing has changed.

    2. Are you using any caching plugin?
    – Nope

    3. What plugins are you using, maybe some plugin is conflicting with Yoast sep?
    – I use only 8 plugins and I tried to turn them off except Yoast SEO but unfortunately the problem remains.

    4. Are you sure you don’t have another sitemap file in public_html directory?
    – I had one but I deleted it days ago.

    5. You can try to disable sitemap functionality in admin under SEO/XML Sitemaps set to disabled and save.
    – Done, but even when the Yoast plugin is disabled, the warning message is visible (strange right?).

    6. Do you have any error_log that can give us some more info?
    – I don’t know what do you mean (I am not a webmaster or SEO expert).

    Thanks man!

    Hi, under number 5 you did it wrong:

    You should not disable Yoast plugin but sitemap functionality, i had the same problem today on another website and that resolved the problem.

    Please read carefully:

    You can try to disable sitemap functionality in admin under SEO/XML Sitemaps set to disabled and save.

    Then enable it again and save.

    Check your sitemap.

    Do you have any other xml file in your public_html directory maybe with some other name?

    Let me know if it works then.

    Branislav

    Hi Branislav,

    in this moment I tried to disable sitemap functionality and, even if it is off, the warning message is still visible. Damn!

    So, if I disable the plugin OR if I disable only the sitemap functionality the warning message remains.

    I don’t know what I can do. 1 week searching the solution :-O

    P.S. it is also strange that, in may case, yoast doesn’t redirect my standard sitemap to yoast sitemap. I thing I have to put some redirect code on .htaccess file.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Sitemap Warning Message’ is closed to new replies.