Support » Plugin: WP Mail SMTP by WPForms » Yet another Gmail/Google whinger!

  • Hi,

    I have followed the instructions to the letter and read http://www.callum-macdonald.com/code/wp-mail-smtp/ but I can’t get SMTP to send, only PHP which isn’t parsing the From_Name

    I read another post that suggested that you should setup an email account with the from email address despite Gmail handling all my email to “trick” it into thinking that the email was being sent locally but that doesn’t work either.

    I’m no expert by any means, but here is my scenario:
    I am running a WP as a multi-site.
    I have DKIM authenticated my email through Google Apps/Gmail.
    The from email I am trying to send from is an alias of the main account.
    The SMTP account that I have in the settings is the main account.
    I am using Gravity Forms which uses wp_mail() hooks

    I think the issue is linked to the DKIM authentication and that I need to edit my SPF record to allow the server used by WP Mail SMTP to send. If this is the case, what server address should I add to my SPF record?

    Here’s my log anyway:

    Test Message Sent
    The result was:
    bool(false)
    The full debugging output is shown below:
    object(PHPMailer)#4472 (69) {
      ["Version"]=>
      string(5) "5.2.7"
      ["Priority"]=>
      int(3)
      ["CharSet"]=>
      string(5) "UTF-8"
      ["ContentType"]=>
      string(10) "text/plain"
      ["Encoding"]=>
      string(4) "8bit"
      ["ErrorInfo"]=>
      string(22) "SMTP connect() failed."
      ["From"]=>
      string(25) "alias@mydomain.co.uk"
      ["FromName"]=>
      string(27) "My Company - Support Team"
      ["Sender"]=>
      string(25) "alias@mydomain.co.uk"
      ["ReturnPath"]=>
      string(0) ""
      ["Subject"]=>
      string(50) "WP Mail SMTP: Test mail to test@testaccount.co.uk"
      ["Body"]=>
      string(68) "This is a test email generated by the WP Mail SMTP WordPress plugin."
      ["AltBody"]=>
      string(0) ""
      ["Ical"]=>
      string(0) ""
      ["MIMEBody":protected]=>
      string(69) "This is a test email generated by the WP Mail SMTP WordPress plugin.
    "
      ["MIMEHeader":protected]=>
      string(467) "Date: Sun, 29 Jun 2014 11:06:42 +0000
    Return-Path:
    To: test@testaccount.co.uk
    From: My Company - Support Team
    Subject: WP Mail SMTP: Test mail to test@testaccount.co.uk
    Message-ID: <07ec35ba819af02854da12b012cc94d4@mycompany.co.uk>
    X-Priority: 3
    X-Mailer: PHPMailer 5.2.7 (https://github.com/PHPMailer/PHPMailer/)
    MIME-Version: 1.0
    Content-Type: text/plain; charset=UTF-8
    Content-Transfer-Encoding: 8bit
    
    "
      ["mailHeader":protected]=>
      string(0) ""
      ["WordWrap"]=>
      int(0)
      ["Mailer"]=>
      string(4) "smtp"
      ["Sendmail"]=>
      string(18) "/usr/sbin/sendmail"
      ["UseSendmailOptions"]=>
      bool(true)
      ["PluginDir"]=>
      string(0) ""
      ["ConfirmReadingTo"]=>
      string(0) ""
      ["Hostname"]=>
      string(17) "mycompany.co.uk"
      ["MessageID"]=>
      string(0) ""
      ["MessageDate"]=>
      string(0) ""
      ["Host"]=>
      string(14) "smtp.gmail.com"
      ["Port"]=>
      string(3) "465"
      ["Helo"]=>
      string(0) ""
      ["SMTPSecure"]=>
      string(3) "ssl"
      ["SMTPAuth"]=>
      bool(true)
      ["Username"]=>
      string(23) "admin@mycompany.co.uk"
      ["Password"]=>
      string(10) "mypassword"
      ["AuthType"]=>
      string(0) ""
      ["Realm"]=>
      string(0) ""
      ["Workstation"]=>
      string(0) ""
      ["Timeout"]=>
      int(10)
      ["SMTPDebug"]=>
      bool(true)
      ["Debugoutput"]=>
      string(4) "echo"
      ["SMTPKeepAlive"]=>
      bool(false)
      ["SingleTo"]=>
      bool(false)
      ["SingleToArray"]=>
      array(0) {
      }
      ["do_verp"]=>
      bool(false)
      ["AllowEmpty"]=>
      bool(false)
      ["LE"]=>
      string(1) "
    "
      ["DKIM_selector"]=>
      string(0) ""
      ["DKIM_identity"]=>
      string(0) ""
      ["DKIM_passphrase"]=>
      string(0) ""
      ["DKIM_domain"]=>
      string(0) ""
      ["DKIM_private"]=>
      string(0) ""
      ["action_function"]=>
      string(0) ""
      ["XMailer"]=>
      string(0) ""
      ["smtp":protected]=>
      object(SMTP)#4470 (12) {
        ["Version"]=>
        string(5) "5.2.7"
        ["SMTP_PORT"]=>
        int(25)
        ["CRLF"]=>
        string(2) "
    "
        ["do_debug"]=>
        bool(true)
        ["Debugoutput"]=>
        string(4) "echo"
        ["do_verp"]=>
        bool(false)
        ["Timeout"]=>
        int(10)
        ["Timelimit"]=>
        int(30)
        ["smtp_conn":protected]=>
        bool(false)
        ["error":protected]=>
        NULL
        ["helo_rply":protected]=>
        NULL
        ["last_reply":protected]=>
        string(0) ""
      }
      ["to":protected]=>
      array(1) {
        [0]=>
        array(2) {
          [0]=>
          string(23) "test@testaccount.co.uk"
          [1]=>
          string(0) ""
        }
      }
      ["cc":protected]=>
      array(0) {
      }
      ["bcc":protected]=>
      array(0) {
      }
      ["ReplyTo":protected]=>
      array(0) {
      }
      ["all_recipients":protected]=>
      array(1) {
        ["test@testaccount.co.uk"]=>
        bool(true)
      }
      ["attachment":protected]=>
      array(0) {
      }
      ["CustomHeader":protected]=>
      array(0) {
      }
      ["lastMessageID":protected]=>
      string(52) "<07ec35ba819af02854da12b012cc94d4@mycompany.co.uk>"
      ["message_type":protected]=>
      string(5) "plain"
      ["boundary":protected]=>
      array(3) {
        [1]=>
        string(35) "b1_07ec35ba819af02854da12b012cc94d4"
        [2]=>
        string(35) "b2_07ec35ba819af02854da12b012cc94d4"
        [3]=>
        string(35) "b3_07ec35ba819af02854da12b012cc94d4"
      }
      ["language":protected]=>
      array(18) {
        ["authenticate"]=>
        string(35) "SMTP Error: Could not authenticate."
        ["connect_host"]=>
        string(43) "SMTP Error: Could not connect to SMTP host."
        ["data_not_accepted"]=>
        string(30) "SMTP Error: data not accepted."
        ["empty_message"]=>
        string(18) "Message body empty"
        ["encoding"]=>
        string(18) "Unknown encoding: "
        ["execute"]=>
        string(19) "Could not execute: "
        ["file_access"]=>
        string(23) "Could not access file: "
        ["file_open"]=>
        string(33) "File Error: Could not open file: "
        ["from_failed"]=>
        string(35) "The following From address failed: "
        ["instantiate"]=>
        string(36) "Could not instantiate mail function."
        ["invalid_address"]=>
        string(15) "Invalid address"
        ["mailer_not_supported"]=>
        string(25) " mailer is not supported."
        ["provide_address"]=>
        string(54) "You must provide at least one recipient email address."
        ["recipients_failed"]=>
        string(45) "SMTP Error: The following recipients failed: "
        ["signing"]=>
        string(15) "Signing Error: "
        ["smtp_connect_failed"]=>
        string(22) "SMTP connect() failed."
        ["smtp_error"]=>
        string(19) "SMTP server error: "
        ["variable_set"]=>
        string(30) "Cannot set or reset variable: "
      }
      ["error_count":protected]=>
      int(2)
      ["sign_cert_file":protected]=>
      string(0) ""
      ["sign_key_file":protected]=>
      string(0) ""
      ["sign_key_pass":protected]=>
      string(0) ""
      ["exceptions":protected]=>
      bool(true)
    }
    The SMTP debugging output is shown below:
    SMTP -> ERROR: Failed to connect to server: Connection timed out (110)

    https://wordpress.org/plugins/wp-mail-smtp/

Viewing 1 replies (of 1 total)
  • hi,

    This sounds like maybe the host is blocking the outgoing mail.

    Depending on your server, if it’s a dedicated, check if you have WHM, then in WHM try allowing Relay mail in Exim.

    It’s always a good idea to setup an SPF record though, the server address would be your domain, and any other domain that you want to allow relays from or to send emails using your servers mail transport.

    It’s been a while since I configured a server for emails, but that’s about the gist of it.

    Hope this helps

Viewing 1 replies (of 1 total)
  • The topic ‘Yet another Gmail/Google whinger!’ is closed to new replies.