Support » Plugin: One Click Demo Import » xml file not importing

  • Resolved mnunan

    (@mnunan)



    Hi, thanks for the fantastic plugin. I have it working for the most part, however the demo data xml file doesn’t seem to be getting imported.

    The url is correct and I have manually checked the file by importing via the wordpress import and that works, so i don’t understand why the demo data is not importing via the one click import.Any ideas please?

    https://wordpress.org/plugins/one-click-demo-import/

Viewing 15 replies - 1 through 15 (of 35 total)
  • same issue here

    Plugin Contributor capuderg

    (@capuderg)

    Hi,

    I’m sorry for the late reply (mnunan), I didn’t get a notification email, but I did get an email for (marsshall) post.

    I have some questions for both of you:

    Are you importing the files manually or are you using a predefined import in the theme?

    If you are using the predefined import:
    Are you importing it from a server (URL) or are you using the local import method?

    What does the log file say? You should have a log file in the *wp-admin -> Media* section.

    Did you try to enable WP_DEBUG in your wordpress site and then try the import again? https://codex.wordpress.org/WP_DEBUG

    Could you please give me the XML file, so I can test it out?

    Take care!

    Hi

    Thanks very much for the reply 🙂

    No worries for me, got it working perfectly 🙂

    Thanks again!

    Hi,
    I am trying to import manualy, no error display. But after succesfull message “That’s it, all done! The demo import has finished” nothing happend. No pages, custom post types, articles imported…Only media images are imported.

    To be honest I can’t remember, I just kept tweaking things and then it worked. Sorry I can’t be of more help :/

    Plugin Contributor capuderg

    (@capuderg)

    Hi marsshall,

    I just tested the manual import and it works fine.

    Could you please send me URL to your log file and the XML file you are trying to import, so I can test it out?

    Take care!

    Here is my log: http://litvanyi.sk/ff/log_file_2016-07-13__12-42-30.txt

    Here is my all files trying to import – http://litvanyi.sk/ff/kosacky.rar

    Problem with custom post type ?

    Plugin Contributor capuderg

    (@capuderg)

    Hi,

    are you testing this on your local machine or is your hosting using Windows servers? Because the file paths look a bit strange…

    I just tested the import and it worked ok. It imported 2 out of 2 pages and also 2 out of 2 posts and also 45 images. All custom post types failed to import (that’s normal, because I didn’t register these custom post types).

    I think that the problem of import not working on your page is server related. Please try the import on a different server and see if it works there.

    Take care!

    Hi,
    here is the new log file – everythings is ok, with upload, only somethings wrong with importing XML data

    http://litvanyi.sk/ff/log_file_2016-07-13__13-29-32.txt

    Yes, I am trying it on my localhost machine with installed EasyPHP Dev server

    You`re right, thats bug only on localhost on windows. Sad, maybe there is some fix for this?

    Thank you, saved me time.

    Plugin Contributor capuderg

    (@capuderg)

    Hi,

    I also tested the import on windows with WAMP server and the import was ok. Maybe a strange configuration of EasyPHP Dev server is the issue?

    Take care!

    Yes, definetly…

    Could I? Is possible to import theme options variable (ACF options page)?
    Only this doesnt work now for me…

    Plugin Contributor capuderg

    (@capuderg)

    What exactly do you mean with ACF import? The import of the ACF xml file? I think you can do that, by importing it just like the demo content.

    Or do you mean something else?

    Are you using this plugin for your own site or are you a theme developer?

    Take care!

    I am having the same problem – it says the import is all done but the xml file is not uploaded except for the images. I actually happen to have Michelle’s (the original poster) successful XML file and I noticed that it had the import log in it – so she must have re-exported the file after she had manually imported the xml file. So I did the same – same as her I had manually imported the xml file and it worked properly. So I exported that file (that contained the import log) and started over with the one click install, and this time it worked! As far as I know the only difference is that the import that worked had the error log file from the first failed import – maybe just a coincidence?

    Plugin Contributor capuderg

    (@capuderg)

    Hi,

    I’m pretty sure that was just a coincidence. I suspect the original import file had some issue, that the new WP importer (which is used in our plugin) couldn’t handle, but I don’t know what the problem would be.

    You also say, that only images got imported… how many images are there to import? Maybe your server ran out of memory and couldn’t finish the import, but that would not leave a success message…

    Hmmm… I don’t know how to help you on this one. Maybe the original import file is at fault and you had to just create a new one…

    Could you please send me both import files (the original import file and the new one), so I can test them out.

    Take care1

Viewing 15 replies - 1 through 15 (of 35 total)
  • The topic ‘xml file not importing’ is closed to new replies.