Support » Plugin: Easy Add Thumbnail » Wrong php version

  • Resolved deepcore2

    (@deepcore2)


    Recently I started loosing featured images. When I stopped and strated this plugin it says I am using an old php version, but my site is running the latest wordpress and php version… Why is the plugin reporting an old version?
    Regards, Peter

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Samuel Aguilera

    (@samuelaguilera)

    There’s not any line of code in this plugin to check your PHP version or display a message about it. So if you’re seeing that message, is WordPress or another plugin showing it, not this plugin.

    deepcore2

    (@deepcore2)

    Stange, because it only occurs when i try to activate this plugin. It will not activate anymore…

    deepcore2

    (@deepcore2)

    I tried to trace back the error message and apparently it came from one of the security plugins. I disabled some and now I can activate the easy add plugin again. Apparently the plugin does not provide a correct minimum level setting somehow. I read that recently wordpress is getting more strick in version checking. Are you sure the pluging reports a minimum level corrcetly? You said it does not check itself, but apparently it needs to report something??

    Plugin Author Samuel Aguilera

    (@samuelaguilera)

    Assuming that you’re seeing the following message after clicking on Activate:

    Error: Current PHP version does not meet minimum requirements for Easy Add Thumbnail.

    That’s WordPress preventing you from activating the plugin for a site running a PHP version older than 7.0. The PHP version required is set in the plugin readme.txt, and WordPress takes this value to know the PHP version the plugin is requiring.

    As said Easy Add Thumbnail doesn’t has any control over your site PHP checking or displaying the error message, that’s entirely handled by WordPress. So if you’re sure your site is running PHP 7.0 or newer and you’re still getting that message, that’s a WordPress issue not a plugin issue, and you should report this to the WordPress core team or ask for help in the WP troubleshooting forum.

    That said, the plugin may work with old PHP versions, but I don’t support using them. So, if you want to still use the plugin with older PHP versions, you can delete the readme.txt file using FTP or a file manager. That should allow you to activate the plugin with any PHP version at your own risk.

    If you’re not seeing the above error message but something different, you will want to investigate the issue further and ask for support to those security plugins you think are related. In any case this is not an Easy Add Thumbnail plugin issue.

    deepcore2

    (@deepcore2)

    I do see exactly that message, well… the dutch translation of it 🙂 I am running PHP 7.3 so that’s not the thing. I’v disabled some plugins and will reactivate them one by one to see where it breaks.

    Am I correct to assume the readme.txt will control the versions? In which case…

    Requires at least: 4.7
    Requires PHP: 7.0

    Should there not be an “at least” for the PHP version???

    Plugin Author Samuel Aguilera

    (@samuelaguilera)

    It’s a minimum requirement, and it’s being set using what the WordPress core team defined for it: https://make.wordpress.org/plugins/2017/08/29/minimum-php-version-requirement/

    As explained previously your issue is with WordPress PHP checking.

    deepcore2

    (@deepcore2)

    You don’t need to repeat yourself, I am not repeating anything. I just think it’s rather accidentally that of the 43 plugins I have enabled, this on is the only one with this issue. So either WordPress core has coded an exception for you, or there might just yet be something wrong. The thread you post is ages old (ok, two years), so thing may have changed. But I’ll just remove the requirement line and see what happens. I’m allways on the latest stable versions anyway.
    Thanx

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.