WordPress.org

Support

Support » Plugins and Hacks » Social » [Resolved] wrong image

[Resolved] wrong image

  • On facebook Social is not publishing the image seen in the preview of the broadcast page, in my case also a featured image, but another image published in the same post (in my case a related post image).
    It worked in the previous version although I couldn’t see any likes or comments from facebook.

    http://wordpress.org/extend/plugins/social/

Viewing 11 replies - 1 through 11 (of 11 total)
  • Same problem here!
    I only have a featured image with the post and the thumbnail that is shown on Facebook isn’t even on the same post on my site.

    Maybe the thumbnail shown in Facebook was taken from de sidebar plugin recent/popular/random ?

    I have the same problem. The images send to facebook seems to be a random image from the page, regardless of if I set a featured image or not.

    Plugin Contributor Alex King

    @alexkingorg

    Social sends an image, but Facebook often decides to use it’s own choice. I recommend installing a plugin that sets Open Graph tags.

    Well, but if I post manually, Facebook fetches the right image 9 out of 10 times. So posting via Social is not a viable alternative at this time, especially if i have to fiddle and configure yet another plugin for it to work.

    I am having this issue as well.

    http://www.facebook.com/linkdeadgaming

    I had it once before, many months ago, and fixed it, but I do not remember how for the life of me. It was a simple mistake one of my writers had made, and when I fixed it, I had the “AHA” moment. Now however, it is driving me insane and I cannot remember how to fix it.

    In short…. HELP!

    It’s too bad, this plugin’s concept is wonderful, but for now I agree with xanathon.

    @crowdfavorite and @alexkingorg :
    Will you try to fix that please?
    For example, sosme plugin such as Network Publisher choose the good image 😉

    Does anyone know if this plugin corrects the problem?

    http://wordpress.org/extend/plugins/wp-facebook-open-graph-protocol/

    As a follow up, I installed the WP Facebook Open Graph Protocol plugin and the correct image was inserted on fb by Social.

    dverbrugge

    @dverbrugge

    Thanks for the follow up!
    I have installed the plugin, but haven’t tested it yet.

    RitaJoC

    @ritajoc

    I just installed the WP Facebook Open Graph Protocol plugin, and it worked on the one post I tested, pulling in the correct image.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Resolved] wrong image’ is closed to new replies.
Skip to toolbar