Support » Fixing WordPress » wp-comments-post.php corrupted??

  • Resolved beyondelsewhere


    So, Sunday people could post comments and today (and possibly Monday) they can’t. Once you hit post all you get is a blank page at And I have no idea why. I haven’t had any problems since I upgraded and I didn’t do anything to my blog this weekend other than post!

    I tried re-uploading the wp-comments-post.php from the 2.3 files that I unzipped, but it didn’t help.

    Help? Please? 🙂

Viewing 15 replies - 1 through 15 (of 16 total)
  • whooami



    Your comments are broke — Firefox wanted to download the file but …

    Just an FYI, the blank page you see when you click teh link above is intentional.

    wp-comments-post.php is not meant to display anything when called directly.

    So dont use THAT alone as an indication that your comments are broke

    Ok… so it is just not loading the comment page then? Because no comments can get through and I haven’t a clue why. 🙁

    I don’t really know a thing about php so if a file corrupted anywhere (somehow) I wouldn’t know where to look. But I have tried to replace all comment-type files and still nothing happens.

    By the way… comments don’t work with ANY theme. So I am totally confused here!

    And now the Visual Editor on my Create a Post page has vanished (even though I have it checked to use in profile). I have tried uninstalling the entire WordPress 2.3 and then reinstalling and NOTHING changes.

    Everything was fine on Sunday. What the heck happened to suddenly break my blog??

    I think this might be a problem at a lower level than WordPress. Is there any way that your .htaccess file could have changed? Or did your web host maybe change something in their Apache configuration?

    If your .htaccess file has rules outside of the WordPress area, post it here for us to check. If not, maybe ask your web host if they upgraded/changed any Apache modules recently. I’ve seen mod_security go haywire if you don’t pay close attention to the rules, for example.

    I tried POSTing a search request to your server, and got back a 500 Internal Server Error. That’s not normal.

    I suppose you could try upgrading to the Release Candidate for WP 2.3.1, but I don’t expect it to fix this problem, really.



    Thank you, thank you for the reply! 🙂

    I have already checked with my web host about changes they might have made. Nothing is different on their end, and they kindly checked all my wordpress files for me and didn’t see any problems.

    My .htaccess file hasn’t changed. In fact I hadn’t made any new changed since upgrading to 2.3 and everything worked like a charm for the first 3 weeks of my upgrade. I find the sudden “break” surprising which is why I checked with my web host after reinstalling WP just in case a file had corrupted.

    My search hasn’t worked for ages and I don’t know why. I just never bothered to fix it. 🙂



    Never believe what a host says; they will hardly admit if they screwed up something…

    As for troubleshouting:
    set your permalinks to default and delete the .htaccess file from the server.
    See if it works.



    Stupid question – how do you delete a hidden file? I ask this with a sheepish grin. 🙂

    EDIT: never mind, I figured it out. Didn’t make any difference though (the deleting the file and setting permalinks to default).



    If it is that hidden… how could you answer above that the .htaccess has not been changed?

    You tell your FTP program to “show hidden files”. It should be somewhere in the settings or who knows. In FileZilla it is under View.



    Well, I know where the file is on my hard drive and have worked on it there, I wasn’t sure how to find it through my FTP client, but I figure it out. I suppose I asked that question prematurely, I apologize.

    I’m no genius when it comes to this stuff, I have enough knowledge to get by fairly well without having too many problems, this one however, is way beyond me. 🙁 So I appreciate the help of those of you who have more than just a clue. 🙂



    Do you have a local installation of WP running xampp or something? Otherwise it doesn’t matter what kind of .htaccess you have on your hard drive.
    What is on your computer has no importance related to what is on your host server! Sorry, it just doesn’t make sense what you are saying…



    Actually, it did make a huge difference: instead of error pages and internal server errors, now you can at least see your single posts.

    Switch to another theme (default). Do the comments work?

    Hi beyondelsewhere: I don’t think I missed it in the posts above, but is your host, by chance the same as mine, GoDaddy? I posted a different problem with comments just a while ago, so no replies yet. But it just started very recently. I have upgraded to 2.3 also and it worked great for a week or two. GoDaddy denies a problem on their end, (like always). Interestingly, I too had a couple of “500 internal server” errors happen to me today and that has never happened before.

    on edit: I now got your site to load for me and I see that you mention your host in one of your posts. Not GoDaddy. So no link there. Thanks.



    Oh! Moshu! The comments are suddenly working in the default theme (which they weren’t before, strange). And upon further inspection, they are now working on my original theme as well! And my Visual editor has suddenly reappeared!

    I guess it was my .htaccess file, though I don’t know why it would suddenly stop working.

    Thank you all very much though, I certainly appreciate the help and troubleshooting!! It all works and I am happy! (I don’t quite understand the .htaccess file, so I think I’ll leave things as is, hopefully that will be safe?)

    Any idea why my site’s comments-post.php looks like this?

    WP_User Object ( [data] => stdClass Object ( [ID] => 1 [user_login] => rpok [user_pass] => $P$Bhin5IkzD60oYvwsc9aGHU7G//IQLj1 [user_nicename] => rpok [user_email] => [user_url] => [user_registered] => 2008-05-26 06:05:31 [user_activation_key] => [user_status] => 0 [display_name] => rpok [nickname] => admin [rich_editing] => true [admin_color] => fresh [wp_capabilities] => Array ( [administrator] => 1 ) [wp_user_level] => 10 [wp_autosave_draft_ids] => Array ( [-1211782659] => 3 [-1211787781] => 4 [-1211788825] => 5 [-1211800085] => 6 [-1211800259] => 7 [-1211804804] => 92 ) [user_level] => 10 ) [ID] => 1 [id] => 1 [caps] => Array ( [administrator] => 1 ) [cap_key] => wp_capabilities [roles] => Array ( [0] => administrator ) [allcaps] => Array ( [switch_themes] => 1 [edit_themes] => 1 [activate_plugins] => 1 [edit_plugins] => 1 [edit_users] => 1 [edit_files] => 1 [manage_options] => 1 [moderate_comments] => 1 [manage_categories] => 1 [manage_links] => 1 [upload_files] => 1 [import] => 1 [unfiltered_html] => 1 [edit_posts] => 1 [edit_others_posts] => 1 [edit_published_posts] => 1 [publish_posts] => 1 [edit_pages] => 1 [read] => 1 [level_10] => 1 [level_9] => 1 [level_8] => 1 [level_7] => 1 [level_6] => 1 [level_5] => 1 [level_4] => 1 [level_3] => 1 [level_2] => 1 [level_1] => 1 [level_0] => 1 [edit_others_pages] => 1 [edit_published_pages] => 1 [publish_pages] => 1 [delete_pages] => 1 [delete_others_pages] => 1 [delete_published_pages] => 1 [delete_posts] => 1 [delete_others_posts] => 1 [delete_published_posts] => 1 [delete_private_posts] => 1 [edit_private_posts] => 1 [read_private_posts] => 1 [delete_private_pages] => 1 [edit_private_pages] => 1 [read_private_pages] => 1 [delete_users] => 1 [create_users] => 1 [unfiltered_upload] => 1 [edit_dashboard] => 1 [manage_ratings] => 1 [administrator] => 1 ) [user_login] => rpok [user_pass] => $P$Bhin5IkzD60oYvwsc9aGHU7G//IQLj1 [user_nicename] => rpok [user_email] => [user_url] => [user_registered] => 2008-05-26 06:05:31 [user_activation_key] => [user_status] => 0 [display_name] => rpok [nickname] => admin [rich_editing] => true [admin_color] => fresh [wp_capabilities] => Array ( [administrator] => 1 ) [wp_user_level] => 10 [wp_autosave_draft_ids] => Array ( [-1211782659] => 3 [-1211787781] => 4 [-1211788825] => 5 [-1211800085] => 6 [-1211800259] => 7 [-1211804804] => 92 ) [user_level] => 10 ) Please enter the authentication code.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘wp-comments-post.php corrupted??’ is closed to new replies.