Support » Plugin: Mandatory Field » WP 3.5

Viewing 14 replies - 1 through 14 (of 14 total)
  • Kramer

    (@kramerkeller)

    Yeah, it doesn’t put the field in red for me either

    Plugin Author ketanmujumdar

    (@ketanmujumdar)

    Ok can you send me a screen shot ? so that i could check in detail…

    Also if possible the screenshot of settings page too….

    Kramer

    (@kramerkeller)

    I am using some custom taxonomies… perhaps that is why the red is not showing up on my fields? i was surprised that is seems to work with my custom taxonomies partly in that it will give me the error saying “Fields marked in RED are mandatory” however it won’t mark the fields in red – so a user wouldn’t know which fields were required and which fields were missing info.

    I can send a screen shot etc… just was curious if this would be expected to work with custom taxonomies and/or if that would cause issues with the mandatory red fields.

    The screenshot isn’t exciting – it would just show the error right below add new post and then everything is the same and nothing is highlighted in red.

    As to the setting page. I just have one required field and it says region – basically i want to require the author to put in the region and some other things before they can post.

    Plugin Author ketanmujumdar

    (@ketanmujumdar)

    Hello Kramer,

    Which out of these three your are using as custom taxonomies?
    Category
    Tag
    Link Category

    As the plugin wont work on Tag, coz the Tag field is always empty. But should work for Categories & mark as red.

    Also in settings you need to add fields name as name:id. so is the “region” an id or a name ?

    if you do not have a name, then you may specify id:id that would work before publishing …

    Thats the reason why i needed a screenshot of both so i could study well and try to reproduce it. So if possible can you send me a link of a screenshot ?

    Plugin Author ketanmujumdar

    (@ketanmujumdar)

    I am resolving the ticket … please let me know if there are any more issues …

    Hey ketanmujumdar,

    I am also not seeing the red show up on categories or featured image when they are not filled out.

    Kramer

    (@kramerkeller)

    Hey Ketanmujumdar,

    Sorry for getting back so late. Okay so I have a few “Custom Taxonomies” that I created. I don’t know what you mean as far as Category, Tag, Link etc… but my custom taxonomies are “Region”, “Skillset” etc. They are not like tags, but more like categories – but again they are custom taxonomies.

    I can send you a screen shot… (just private message I guess?)

    But basically it just shows the “Fields marked in RED are mandatory” error at the top and then “Region” which looks just like Categories, but is a custom taxonomy… doesn’t have red around it.

    Kramer

    (@kramerkeller)

    Also,

    One more thing… I know how to get he ID of my terms, but not the ID of the actual custom taxonomy… everytime I look it up, i am seeing how people find the term ID – for terms within the taxonomy, but not the actual ID of the custom taxonomy itself. For instance… what would Category’s ID be and what would my Region’s ID be?

    Plugin Author ketanmujumdar

    (@ketanmujumdar)

    Hi,

    Please email me the screenshot @ ketanmujumdar@gmail.com, so that i can help you in a better way.

    Regards,
    Ketan Mujumdar

    Plugin Author ketanmujumdar

    (@ketanmujumdar)

    Hello hornets2002,

    The categories works if none is selected. Please mention the issue in detail.

    Regards,
    Ketan Mujumdar

    Hi Ketan,

    I’m afraid I am also not seeing the red border appear around mandatory fields. I would love to get this working properly as it is a beautifully simple plugin, perfect for my needs and I will happily recommend it to others.

    Many thanks,
    Josh

    Plugin Author ketanmujumdar

    (@ketanmujumdar)

    Hi Josh,

    Can you please email me the screenshot ? My email ketanmujumdar@gmail.com. I can assist you better, also please email me the screenshot for the settings page.

    Regards,
    Ketan Mujumdar

    Hi Ketan,
    Thank you for your quick response and support. Brilliant plug in!

    A note for anyone else having difficulty seeing the red border:
    In settings I was entering ‘#mp_file’ when I should have entered ‘mp_file:mp_file’. No class/id selectors required.

    Many thanks,
    Josh

    Plugin Author ketanmujumdar

    (@ketanmujumdar)

    That’s gr8 I could help you out. Please if you could give a review and rate my plugin that would be gr8 ..

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘WP 3.5’ is closed to new replies.