Support » Fixing WordPress » (WP 2.7.1) Warning: htmlspecialchars_decode() Error when posting source code

  • Resolved stein

    (@stein)


    Hello,

    Since I updated to 2.7.1 I have no longer been able to post any source code without triggering an error; except by disabling the syntax highlighting plugin I use (Syntaxhighlighter). I tried other similar plugins to see if it was a plugin error but not even the 2-day-ago updated Syntaxhighlighter Plus worked.

    The error appears when attempting to publish/save/preview any post containing [code] or [sourcecode] tags and this appears:

    Warning: htmlspecialchars_decode() expects parameter 1 to be string, NULL given in /home/iniciat/public_html/main/wp-includes/compat.php on line 105

    Warning: Cannot modify header information – headers already sent by (output started at /home/iniciat/public_html/main/wp-includes/compat.php:105) in /home/iniciat/public_html/main/wp-includes/pluggable.php on line 850

    Any help will be very appreciated,

    thanks

Viewing 5 replies - 1 through 5 (of 5 total)
Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘(WP 2.7.1) Warning: htmlspecialchars_decode() Error when posting source code’ is closed to new replies.