Support » Plugin: ReactPress - Create React App for Wordpress » Worst WordPress Plugin

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author rockiger

    (@rockiger)

    Could you please tell me, how ReactPress downs you site? What doesn’t work as expected?

    Thread Starter parthsatasiya

    (@parthsatasiya)

    Yeah,

    1st thing – In type field -> Develop a new app <— This option is disabled in all OS, I tried it in macOS, Windows, Linux.

    2nd thing – I have added my project folder in the apps folder, so it’s working when I run the command “yarn start”. But after then build the app, it doesn’t work. let’s suppose I have an “xyz” project in the apps folder and the slug URL is “xyz”. Now I have created a build folder using the “npm run build” command. then I will check the URL in “localhost/abc/wp-admin/xyz”. but it doesn’t work, it redirected me to the URL “localhost/dashboard”. even in the console, I am not getting any errors.

    Thank you for your support

    Plugin Author rockiger

    (@rockiger)

    The “Develop a new app” option only works when certain conditions are met. Unfortunately this doesn’t work with most dev environments. For me it only worked with Bitnami installer on Ubuntu. This is why I created “manual mode”.

    To create a new app, you need to follow precisely these steps:

    1. cd to [PATH_TO_PLUGINS]/plugins/reactpress/apps/
    2. npx create-react-app [APPNAME]
    3. Reload the ReactPress page in WP-Admin and set a page slug for your app that is not used by any other page.

    4. cd [APPNAME]

    5. yarn build
    6. Click on the slug in the WP-Admin and your built app should be there.

    If you don’t see the rotating React logo, try to use a different WordPress dev environment. I recommend Local.

    Plugin Author rockiger

    (@rockiger)

    Did this solve your problems? If yes, could you please change your review?

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Worst WordPress Plugin’ is closed to new replies.