Support » Plugin: NextScripts: Social Networks Auto-Poster » wordpress.com error 301 Moved Permanently

  • Resolved Tigr

    (@tigr)



    Here is something quite puzzling. I have a couple of blogs on wordpress.com under the same account (same username). One of them publishes just fine. The other one gives me 301 Moved Permanently. I am flabbergasted. Any idea why this might be happening?

    Array
    (
        [pgID] =>
        [isPosted] => 0
        [pDate] => 2014-12-05 17:18:03
        [Error] => -=ERROR=- transport error - HTTP status code was not 200 - 0 -  | HTTP/1.1 301 Moved Permanently
    Server: nginx
    Date: Fri, 05 Dec 2014 17:17:51 GMT
    Content-Type: text/html
    Content-Length: 178
    Connection: keep-alive
    Location: https://holyhash.wordpress.com/xmlrpc.php
    X-ac: 1.fra _sat

    https://wordpress.org/plugins/social-networks-auto-poster-facebook-twitter-g/

Viewing 13 replies - 1 through 13 (of 13 total)
  • WP.com is extremely helpful as usual:

    “That looks like a plugin for WordPress.org (self-hosted sites). Those aren’t available for blogs at WordPress.com. Instead, you could use Publicize to achieve a similar result”

    Plugin Author NextScripts

    (@nextscripts)

    This issue has been fixed in the version 3.4.5. Please update your plugin.

    Sorry – still the same error after update…

    3.4.5 does not address the problem, fails with the same message.

    Plugin Author NextScripts

    (@nextscripts)

    I probably forgot to mention. You also need to update your xmlrpc URL.

    WordPress.com moved some accounts to “https” only.

    If you still have http://holyhash.wordpress.com/xmlrpc.php you need to change it to https://holyhash.wordpress.com/xmlrpc.php and it will work.

    Ah, good catch. It did successfully post after I changed to https. Thanks a bunch!

    problem still persist!!

    Testing …

    Array
    (
    [pgID] =>
    [isPosted] => 0
    [pDate] => 2014-12-17 06:24:57
    [Error] => -=ERROR=- transport error – HTTP status code was not 200 – 0 – | HTTP/1.1 404 Not Found
    Server: nginx
    Date: Wed, 17 Dec 2014 06:24:58 GMT
    Content-Type: text/html; charset=UTF-8
    Transfer-Encoding: chunked
    Connection: keep-alive
    Vary: Accept-Encoding
    X-hacker: If you’re reading this, you should visit automattic.com/jobs and apply to join the fun, mention this header.
    X-Pingback: https://animetoshare.wordpress.com/xmlrpc.php
    Expires: Wed, 11 Jan 1984 05:00:00 GMT
    Cache-Control: no-cache, must-revalidate, max-ag

    No, in your case the problem is different. Notice how the server reported with “HTTP/1.1 404 Not Found”. That means the URL was not there when you called. I tried that URL and it works though, you may want to simply try again, perhaps your blog was new and their platform was not ready yet to serve your blog over rpc?

    Hi Tigr,

    perhaps your blog was new and their platform was not ready yet to serve your blog over rpc

    –> Do you know and could you tell me how long my new blog should exist?

    Best Regards!

    same problem.
    Solved:
    If you got 301 error – just try to copy address from Location field (from response) and paste it to XMLRPC address URL parameter
    for first message is:
    Location: https://holyhash.wordpress.com/xmlrpc.php

    I can publish new post all am seeing is 301 Moved Permanently
    Http//:9jablinkzmusic.wordpress.com

    I can’t publish new post all am seeing is 301
    Moved Permanently
    Http//:9jablinkzmusic.wordpress.com

    I can’t publish new post all am seeing is 301
    Moved Permanently
    Http//:9jablinkzmusic.wordpress.com

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘wordpress.com error 301 Moved Permanently’ is closed to new replies.