Support » Fixing WordPress » WordPress has changed my javascript code.

  • Hello,

    I was instructed to put the following code into my website:

    <script language="javascript"
    src="http://cache.blogads.com/858400020/feed.js"></script><br/><a
    href="http://www.blogads.com">blog advertising</a> is good for you

    So I put it in a text widget. However, after the page loads in my browser, the code looks like this if I view page source:

    <script language="javascript"
    data-djssrc="http://cache.blogads.com/858400020/feed.js" type="text/djs" >
    </script>
    <br/>
    <a href="http://www.blogads.com">blog advertising</a> is good for you

    Note the differences like “src” has been replaced by “data-djssrc” and type=”text/djs” has also been inserted by itself. Can anyone explain what is causing this and whether this is stopping it from running.

    Thank you very much for your help.

Viewing 3 replies - 1 through 3 (of 3 total)
  • I have been having the exact same issue… and its really screwing up the way my site loads and functions!

    Do you, by any chance, have CloudFlare enabled? I’m thinking this may be an issue with the beta “minify” feature.

    I’ll let you know if I find anything more.

    DouglasSteinberg

    Yep, turns out it was CloudFlare that was screwing me up. I just got off the phone with support and their explanation was that this feature “is not ready for implementation.” I’m still not sure why they have it as an option. FTW. Just disable that, wait about 30 minutes, and you should have your fancy javascript up and working again.

    Cheers!

    Hi,
    I just got the same issue.
    It turned out to be the “Rocket Loader” thing:
    https://twitter.com/#!/CloudFlare/status/128564202406285312

    the Minify feature seems to be working ok. I disabled Rocket Loader and my script worked fine again!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘WordPress has changed my javascript code.’ is closed to new replies.