WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] WordPress 3.8 upgrade image upload not working

[Resolved] WordPress 3.8 upgrade image upload not working

  • alijam668
    Member

    @alijam668

    I upgraded to 3.8 yesterday and since then images are not uploading completely (they worked fine before the upgrade). I’m not getting an error as such – if I go to the media library and add new, the upload appears to work but (a) there is no thumbnail (b) the images won’t appear in the header (or whereever I am trying to put them). Looking at the upload folder on the server the image does appear to have uploaded successfully, it’s almost as though WordPress doesn’t know where it is.

    I have seen a few other posts about this and have tried some of the suggestions:

    I’ve disabled all plugins
    I’ve renamed the plugins folder
    I’ve tried going back to the default (2013) theme

    None of these make any difference.

    All advice welcome, but please note I’m new-ish to WordPress.

Viewing 3 replies - 1 through 3 (of 3 total)
  • WPyogi
    Forum Moderator

    @wpyogi

    Have you checked the file permissions?

    http://codex.wordpress.org/Changing_File_Permissions

    alijam668
    Member

    @alijam668

    Sorry for delay – YES!! Thank you v much WPyogi the upload folders were all set to 744 from Nov onwards so I’ve chmod’d all to 755 and it is now working. Thanks again for your help – much appreciated!
    I will set this to resolved

    I had the same problem and it started in January 2014. This was because the WordpPress created the ‘2014’ folder automatically but it was assigned 744 instead of 755 whereas ‘2013’ folder was assigned 755 permissions. Very silly error if you ask me!

    I’m on shared hosting so I just went into cPanel and changed the permissions via the file manager. Problem solved instantly

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] WordPress 3.8 upgrade image upload not working’ is closed to new replies.