WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] WordPress 3.1.2 Permalink Problem

[Resolved] WordPress 3.1.2 Permalink Problem

  • I’ve been developing a couple of websites locally and installed the latest version of WordPress – 3.1.2.

    When I attempted to look over the sites to make sure everything was running correctly, Only the main page of the website was viewable. The blog section could not be accessed and kept throwing up an error 404.

    The strange thing is, when I go to a particular post and save it back to Draft, it is then possible to view it. When published, nothing.

    I changed the permalink structure from /%postname%/ back to the WP default, low and behold, everything is running as it should. However, this particular structure is not suitable for the running of the website and I need to use the /%postname%/ permalink structure.

    It would appear that this latest version of WP has broken the permalink structure in some way.

    Is there a workaround for this does anyone know??

    Thanks in advance.

Viewing 15 replies - 1 through 15 (of 23 total)
  • Is mod_rewrite ON in your Apache

    Yes it is on Govpatel. Everything was working perfectly prior to this upgrade. 🙂

    I do not have any problem and I am using the same version
    with /%postname%/ in custom structure.

    Well I’m happy to hear your having no problems with the permalink structure. The fact that I am after this upgrade is all that matters here.

    As a rule, most WP installs go fairly well. This is the first time in 10 years that I have any kind of problem.

    I am looking for a solution here.

    It’s been resolved.

    Can we know what you did to solve the problem

    Been experiencing the same problem. It works with the default permalink structure, but not with any modified. so Eff Ess, if you’ve came up with a solution it’d be great if you could post it.

    I just upgraded a site from 3.1 to 3.1.2. I found that pages were fine but custom posts returned 404.

    Downgrading to 3.1 fixed it.

    How do you downgrade back?!

    I followed the process for manually upgrading – http://codex.wordpress.org/Updating_WordPress – but used an older version of WordPress instead of a new one.

    However, for this particular permalink problem, I’m not convinced it’s a 3.1.2 problem. If you find that your custom posts return 404, try clicking Permalinks in Settings in the Admin, then reloading your custom post page.

    What about the fatal error problem

    I am having the same problem now also. My custom Permalink structure is “/index.php/%postname%/” If I change to use the default Permalink, everythign works great. Anytime I change to one of the other permalinks, I receive the 404 errors.

    What other options are there, other than downgrading?

    – Brendan

    Try just /%postname%/

    Gov, thanks for the quick feedback, but no luck. 🙁 I still receive the same error. Did you have to change any other code (i.e. function.php) to get this working?

    http://sjrtheater.com/btw/

    Check with your host if they Mod_rewrite ON as that is what you need to rewrites links.

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘[Resolved] WordPress 3.1.2 Permalink Problem’ is closed to new replies.