WordPress.org

Support

Support » Plugins and Hacks » Wordbooker » wordbooker wont auth

wordbooker wont auth

  • endless loop of authorizing… says it does and to reload page… but on reload a still wants you to auth…

Viewing 15 replies - 1 through 15 (of 25 total)
  • Plugin Author Steve

    @steveatty

    Can you please post the support information from the bottom of the page. Also did you have Wordbook installed before Wordbooker? If you did you must de-activate Wordbook properly through the plugins panel before activating Wordbooker.

    Hi,

    Me too. Same problem. Authorization worked fine on main site of MultiSite install but failed in an endless loop for a sub-site. Never had Wordbook, sub-sites in subdirectory as opposed to subdomain, the blog in question is blog_id 2 and finally I’m using WordPress MU Domain Mapping to make it look like the sub-site is at the root of it’s own domain.
    (www.sub-site.com vs. http://www.main-site.com/sub-site)

    Wordbooker info:
    Please provide the following information about your installation:

    * Wordbooker: 1.8.16
    * Wordbooker Schema: 8
    * WordPress: 3.0.1
    * PHP: 5.2.12
    * JSON Encode: PHP
    * JSON Decode: PHP
    * Curl Status: Curl can access Facebook – All is OK
    * Fopen Status: Fopen is available and can access Facebook – All is OK
    * JSON Version: 1.2.1
    * SimpleXML library: PHP
    * HTTP Output Character Encoding: pass
    * Internal PHP Character Encoding: UTF-8
    * MySQL: 5.0.86
    * Facebook Transaction limit: 40
    * Database character_set_client : utf8
    * Database character_set_connection : utf8
    * Database character_set_database : latin1
    * Database character_set_filesystem : binary
    * Database character_set_results : utf8
    * Database character_set_server : latin1
    * Database character_set_system : utf8
    * Database character_sets_dir : /usr/local/share/mysql/charsets/
    * Database collation_connection : utf8_general_ci
    * Database collation_database : latin1_swedish_ci
    * Database collation_server : latin1_swedish_ci
    * Server : Apache
    * Active Plugins : (this field was empty)

    Plugin Author Steve

    @steveatty

    Max – you have a very specific problem which I’m sure is related to the use of the domain mapping plugin.

    You should be getting some diagnostics but what I suspect is happening is that the callback url (which is derived from the “wpurl” WP configuration item is not working properly.

    Unfortunately I can’t test against that plugin due to DNS limitations imposed by my Domain registrar.

    Hi Steve,

    My options table option_name: site_url for the sub-site (blog_id 2 in the blogs table) shows the siteurl to be in the pattern of
    http://www.main-site.com/sub-site/.
    I’ll do some work on it and let you know what I find.

    Regards

    Hi Steve,

    Just FYI,

    I went through every url generated by Wordbooker to communicate with Facebook on my working main site, and compared them with what the variables were being populated with by WordPress MU Domain Mapping rewrites on my sub-site. Everything looked like it should have been working.

    In reading everything available I came upon this statement on your website, http://blogs.canalplan.org.uk/steve/wordbooker/ :
    “Wordbooker works with WordPress 3.01 in single and multi-site modes but cannot be activated network wide. This will be rectified in Wordbooker 2.0 which is currently under development.”

    Now, I had not read this on the installation tab on WordPress.org or in the installation section of your wordbooker_user_guide pdf. When I activated Wordbooker I did use network activation. So I deactivated the plugin and reactivated it separately for each site. After that Wordbooker successfully proceeded to authorize and post to Facebook on my sub-site.

    I think maybe this information should be featured a little more prominently in the installation instructions, seeing as how network activation broke Wordbooker on my sub-site. But the good news is Wordbooker works (at least as far as posting) on a subdirectory multi-site installation using the domain mapping plugin. Now I’ll be exploring things like cross-pollinating comments.

    Regards

    Plugin Author Steve

    @steveatty

    As I’m changing it all under V2 its moot really – the reason it doesn’t work under Network activation is that there isn’t any way in the code to determine which blog its being activated for – and turning it on on a big site would be crazy due to the number of tables it would have to create.

    Steve, thanks for the great plugin.

    Will V2 installation requite a reauthorization of all facebook accounts that are connected to subdomain sites?

    Plugin Author Steve

    @steveatty

    Version 2 uses a completely different DB structure and you’ll need to re-auth each WordPress account/FB account. But there will only be 1 association between WP user and FB ID across the whole of a Networked blog install, rather than the current one per blog.

    Thanks for the quick reply, Steve.

    When I post from my Droid phone via the WordPress app, it is not posting to my Facebook. Is there a setting that I can adjust to allow this, or is this not possible?

    Plugin Author Steve

    @steveatty

    Which version are you using? Are you using the XMLRPC protocol to post? There seems to be some problems with some remote clients which I’m having major problems sorting out because I don’t actually own most of the phones!

    If you look at the bottom of wordbooker.php you should see:

    #add_action(‘xmlrpc_publish_post’, ‘wordbooker_publish_remote’);

    try removing the # from the start of the line.

    I’m using Version 1.8.18

    The # is already removed from that line.

    My phone is the Droid 1 (original).

    Plugin Author Steve

    @steveatty

    Well its unlikely that if its a bug in the code that it will be fixed in 1.x as I’m trying to concentrate on the code for Version 2.

    Download the latest file set ( http://www.pemmaquid.plus.com/wordbookerdebug181804.zip) and upload the files over the existing ones.

    Then turn on the advanced diagnostics and do a post from your phone and it should give a diagnostic trace on the Wordbooker Options page. Are you using the official WP app for android?

    Yes, I am using the official WP app. I updated the files as you said. I then removed the * as you previously stated. I turned on the advanced diag. Still not working.

    Is there a way I can send you a copy of the diagnostics to look at?

    I am having the same problem, and not on multi-site. I log in, it says it was successful and asks to reload. When I do, it wants me to reauthorize. It was working fine until a recent update (can’t tell you which version unfortunately).

    Here’s the diagnostic info:

    Diagnostic Messages

    Timestamp Post Diagnostic Message Diagnostic Data
    2011-01-07 12:03:41 Everything looks good so lets ask them to refresh ( )
    2011-01-07 12:07:53 Checking Session ( )
    2011-01-07 12:07:53 Getting Userdata ( )
    2011-01-07 12:07:53 Checking session (2) ( )
    2011-01-07 12:07:53 No Session Found ( )
    2011-01-07 12:07:53 No session found – lets login and authorise ( )

    Wordbooker: 1.8.20
    Wordbooker Schema: 10
    WordPress: 3.0.4
    PHP: 5.2.12
    JSON Encode: provided by PHP
    JSON Decode: provided by PHP
    Curl Status: Curl is available and can access Facebook – All is OK
    Fopen Status: Fopen is available and can access Facebook – All is OK
    JSON Version: 1.2.1
    SimpleXML library: 0.1 (provided by PHP)
    HTTP Output Character Encoding: pass
    Internal PHP Character Encoding: UTF-8
    MySQL: 5.0.51a
    Facebook Transaction limit: 40
    Database character_set_client : utf8
    Database character_set_connection : utf8
    Database character_set_database : latin1
    Database character_set_filesystem : binary
    Database character_set_results : utf8
    Database character_set_server : latin1
    Database character_set_system : utf8
    Database character_sets_dir : /usr/local/mysql-5.0.83-linux-x86_64-icc-glibc23/share/mysql/charsets/
    Database collation_connection : utf8_general_ci
    Database collation_database : latin1_swedish_ci
    Database collation_server : latin1_swedish_ci
    Server : Apache/2
    Active Plugins :
    Akismet ( 2.5.1 )
    Disqus Comment System ( 2.61 )
    FeedWordPress ( 2010.0905 )
    Google XML Sitemaps ( 3.2.4 )
    Greg’s High Performance SEO ( 1.4.5 )
    Page Links To ( 2.4 )
    RB Internal Links ( 2.0.12 )
    Smart Youtube ( 3.8.3 )
    Social Bookmarks ( 4.1.6 )
    Twitter Tools – Bit.ly URLs ( 2.4 )
    Twitter Tools – Hashtags ( 2.4 )
    Twitter Tools ( 2.4 )
    Ultimate Google Analytics ( 1.6.0 )
    WordPress Mobile Edition ( 3.1 )
    WordPress Popular Posts ( 2.1.4 )
    wp-jquery-lightbox ( 1.2.1 )
    Yet Another Related Posts Plugin ( 3.1.9 )

    Plugin Author Steve

    @steveatty

    Have you added any other plugins recently? Can you check your php error logs and see if there are any errors being thrown

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘wordbooker wont auth’ is closed to new replies.
Skip to toolbar