Support » Plugin: Simple Fields Map extension » Won't Activate

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Pär Thernström

    (@eskapism)

    The plugin requires php 5.3 or higher. That may not be mentioned in the readme. Sorry about that.

    Is There a way to make it work on PHP 5.2.x ? i can`t update my php version
    I really need this plugin and didnt found anything similar =(
    thanks

    bwords84

    (@bwords84)

    Hi Pär,
    I hope you’re well, just trying your plugin.

    Similar problem to the above – when I activate the map extension:
    Parse error: syntax error, unexpected T_FUNCTION in simple-fields-map-extension.php on line 107

    My server is running php 5.3.
    Wordpress Version 3.6
    Simple fields Version 1.4.2
    Map extension Version 1.3.2

    Any advice would be greatly appreciated.
    ** WARNING ** my coding understanding is limited.

    Best wishes,
    Ben

    Plugin Author Pär Thernström

    (@eskapism)

    It should work on that setup. The error occurs on a row that uses an anonymous function (see here: https://github.com/EarthPeople/WP-Simple-Fields-Map-Extension/blob/master/simple-fields-map-extension.php#L107), but you have php version 5.3 and then they should work. According to for example this page it’s available in 5.3: http://www.toosweettobesour.com/2008/07/21/php-53-and-closures/.

    So.. don’t know what I can do to fix this. Can you upgrade your version of PHP and see if that helps?

    bwords84

    (@bwords84)

    Many thanks for getting back to my post so quickly.
    Not to worry, just wondered if you’d come across it before.
    I will keep digging.

    Best wishes,
    Ben

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Won't Activate’ is closed to new replies.