WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Widgets.php error since upgrade to 2.3.2

[Resolved] Widgets.php error since upgrade to 2.3.2

  • I recently upgraded my wordpress from 2.2 to 2.3.2

    Normally an upgrade just takes 25minutes, including makein the backups.

    I have struggled for the last 2 hours with errors that I don’t know how to fix.

    Alls of them have to do with the widgets.php

    For example

    Fatal error: Cannot use string offset as an array in /home/site/public_html/wp-includes/widgets.php on line 533

    Fatal error: Cannot use string offset as an array in /home/site/public_html/wp-includes/widgets.php on line 618

    Line 533 is:
    $title = $options[$number][‘title’];

    Line 618 is:
    $c = $options[$number][‘count’] ? ‘1’ : ‘0’;

    How can I fix this?

Viewing 3 replies - 1 through 3 (of 3 total)
  • To fix the problem delete:

    define(‘DB_CHARSET’, ‘utf8’);
    define(‘DB_COLLATE’, ”);

    in wp-config.php

    Thanks, John25. FYI, this solves the wp_terms errors mentioned elsewhere as well.

    Thanks to John25 for this solution. I had the same problem after upgrading to 2.3.3. This solution worked on this version as well.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] Widgets.php error since upgrade to 2.3.2’ is closed to new replies.