WordPress.org

Support

Support » How-To and Troubleshooting » Widgets don’t work

Widgets don’t work

  • I’ve posted this before but my topic is closed so i will never get an answer. If i did something wrong please let me know.

    My sidebar looks like this after making the modifications recommended. Widgets still don’t work though. Do i still have to add additional code to function.php? If so; would someone please explain what and where exactly the modifications have to be made to make a theme widget aware?

    Please some help….

    I did try this: http://automattic.com/code/widgets/themes/ but with no satisfying result.

    </div>
    <div id="sidebar">
    <ul>
    <?php
    if ( function_exists('register_sidebar') )
        register_sidebar();
    ?>
    <ul>
    <?php wp_list_categories('title_li=<h2>Categories</h2>'); ?>
    </ul>
    
    <ul>
    <li><h2>Archives</h2>
    	<ul>
    		<?php wp_get_archives('type=monthly&limit=6'); ?>
    	</ul></li>
    </ul>
    <ul>
    <li><h2>Meta</h2>
    	<ul>
    		<?php wp_register(); ?>
    		<li><?php wp_loginout(); ?></li>
    		<li><a href="http://wordpress.org/" title="Powered by WordPress.">WordPress</a></li>
    		<?php wp_meta(); ?>
    	</ul></li>
    </ul>
    <?php endif; ?>
    </ul>
    </div>

    Thanks a lot for helping.

Viewing 1 replies (of 1 total)
  • Ditto. Would someone please tell me why my widget page has this:
    Fatal error: Cannot redeclare register_sidebars() (previously declared in /home/content/d/e/a/deadmule54/html/wp-includes/widgets.php:13) in /home/content/d/e/a/deadmule54/html/wp-content/plugins/widgets.php on line 22

    It’s been that way since before 2.5.1 upgrade.

    Thanks for any and all help on this.

Viewing 1 replies (of 1 total)
  • The topic ‘Widgets don’t work’ is closed to new replies.
Skip to toolbar