Support » Plugin: YOP Poll » Why read capability?

  • Resolved Hassan

    (@hassanhamm)


    I have noticed that YOP Poll plugin requires the capability read to allow access to all of its menu items. This capability is the “weakest” one, i.e. it allows ANYONE to create/edit polls etc.

    I suggest you change it to something more appropriate like edit_pages

    http://wordpress.org/extend/plugins/yop-poll/

Viewing 7 replies - 1 through 7 (of 7 total)
  • In fact, you should assign different capabilities for different menu items as appropriate. For example the manage_options capability for the Options menu etc.

    Plugin Author YOP

    (@yourownprogrammer)

    Hi Hassan,

    We take account of your suggestions and implement them in the future.

    Best regards,

    YOP Team

    Thank you.

    Any ETA for the next release (4.3 I guess)?

    Plugin Author YOP

    (@yourownprogrammer)

    Hi Hassan,

    We can not give you an exact date for our next release.
    We are currently working on the new version and we still have some things to adjust.

    Best wishes,

    YOP Team

    Why not fixed in v4.3?

    Plugin Author YOP

    (@yourownprogrammer)

    Hey Hassan,

    Our plugin has a separate capabilities system so “read” does not affect its security.

    Regards,

    YOP Team

    Ah, I see. Good to know.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Why read capability?’ is closed to new replies.