Support » Plugin: Cerber Security, Antispam & Malware Scan » Weekly reports setting changing when upgrading

  • markpack

    (@markpack)


    Each time a new version of the plugin comes out and I upgrade my multisite install, I find that the setting under Notifications / Weekly Reports / Enable reporting has flipped to on. If I turn if off, that off setting works fine… until the next plugin update, when doing the update flips it back to on.

    I think this counts as a bug, as updates should leave user settings alone, or at the very least prompt the user to check if they want to change their setting?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Gioni

    (@gioni)

    Those settings are enabled by default on a fresh install only, upgrading plugin should not change plugins settings at all. Probably this is a bug that is related to multisite installation or a multisite WP bug can cause this. I’ll look into it ASAP.

    markpack

    (@markpack)

    In case it’s useful to know: this problem happened again when updating to the new 7.8.5 (i.e. the fixes in there didn’t resolve this for me). Thanks.

    Plugin Author Gioni

    (@gioni)

    How did you update the plugin? Manually? Please explain.

    markpack

    (@markpack)

    I clicked the update option from the plugins admin page (i.e. I didn’t download the zip file and then manually update the plugin).

    markpack

    (@markpack)

    Hi – this bug is still there I’m afraid. I just updated to v7.9.7 on WordPress 5.0.3 and the same thing happened with the setting resetting itself.

    Plugin Author Gioni

    (@gioni)

    Does it happen only to that particular setting?

    markpack

    (@markpack)

    Yup, it looks to be just that one setting which resets.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Weekly reports setting changing when upgrading’ is closed to new replies.